Closed Bug 1605161 Opened 3 years ago Closed 3 years ago

The muxer shouldn't include search shortcuts/keyword offers in the suggestions bucket

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 74
Iteration:
74.2 - Jan 20 - Feb 09
Tracking Status
firefox74 --- fixed

People

(Reporter: adw, Assigned: mak)

References

Details

Attachments

(1 file)

By default the muxer has two buckets, suggestions and general. It incorrectly includes search shortcuts (keyword offers) in the suggestions bucket. They are search results but they're not suggestions. The muxer just isn't checking for suggestions like it should be, seems like.

This problem was originally discussed in the context of the the top-sites experiment in bug 1547287 and https://github.com/0c0w3/urlbar-top-sites-experiment/issues/3

This is marked as 3 points in the breakdown spreadsheet, so updating

Points: 2 → 3
Blocks: 1607475
No longer blocks: 1607475
Duplicate of this bug: 1607475
Priority: P1 → P2
Assignee: nobody → mak
Status: NEW → ASSIGNED
Iteration: --- → 74.2 - Jan 20 - Feb 09
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/f937a6d383aa
The muxer shouldn't put non-search-suggestions results in the suggestions bucket. r=adw
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Duplicate of this bug: 1577546
You need to log in before you can comment on or make changes to this bug.