Closed Bug 1605188 Opened 9 months ago Closed 8 months ago

Update builders to rustc 1.41

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(firefox75 fixed)

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: chmanchester, Assigned: chmanchester)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 1 obsolete file)

No description provided.
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6a1a55bc4edf
Update builders to rustc 1.40 r=firefox-build-system-reviewers,rstewart
Assignee: cmanchester → rob
Status: NEW → ASSIGNED
Assignee: rob → cmanchester
Status: ASSIGNED → NEW
Attachment #9123332 - Flags: review?(geoff)
Attachment #9123332 - Attachment is obsolete: true
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla74

Backed out for webrender and wrench bustages. These are being detected with delay, see bug 1576040

backout: https://hg.mozilla.org/mozilla-central/rev/86b7021079e538c062e2be8550f1be90a1eca2a6

push: https://treeherder.mozilla.org/#/jobs?repo=autoland&group_state=expanded&revision=6a1a55bc4edffcbb799d8e27ba8364a268e29937&searchStr=webrender&selectedJob=286768392

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=286768392&repo=autoland

[task 2020-01-28T21:54:17.029Z] warning: clang-9: warning: argument unused during compilation: '--rtlib=compiler-rt' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:17.029Z] warning: clang-9: warning: argument unused during compilation: '-fuse-ld=/builds/worker/fetches/cctools/bin/x86_64-apple-darwin-ld' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:17.029Z] warning: clang-9: warning: argument unused during compilation: '--rtlib=compiler-rt' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:17.029Z] warning: clang-9: warning: argument unused during compilation: '-fuse-ld=/builds/worker/fetches/cctools/bin/x86_64-apple-darwin-ld' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:17.030Z] warning: clang-9: warning: argument unused during compilation: '--rtlib=compiler-rt' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:17.030Z] warning: clang-9: warning: argument unused during compilation: '-fuse-ld=/builds/worker/fetches/cctools/bin/x86_64-apple-darwin-ld' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:17.030Z] warning: clang-9: warning: argument unused during compilation: '--rtlib=compiler-rt' [-Wunused-command-line-argument]
[task 2020-01-28T21:54:19.382Z] error: build failed
[fetches 2020-01-28T21:54:19.384Z] removing /builds/worker/fetches
[fetches 2020-01-28T21:54:20.178Z] finished
[taskcluster 2020-01-28 21:54:20.827Z] === Task Finished ===
[taskcluster 2020-01-28 21:54:20.924Z] Artifact "public/build/cargo-test-binaries.tar.bz2" not found at "/builds/worker/artifacts/cargo-test-binaries.tar.bz2"
[taskcluster 2020-01-28 21:54:21.240Z] Unsuccessful task run with exit code: 101 completed in 415.753 seconds

and

failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=286768031&repo=autoland

[task 2020-01-28T21:45:54.984Z] Running rustc --edition=2018 --crate-name max_size peek-poke/tests/max_size.rs --error-format=json --json=diagnostic-rendered-ansi --emit=dep-info,link -C debuginfo=2 --test --cfg 'feature="default"' --cfg 'feature="derive"' --cfg 'feature="euclid"' --cfg 'feature="extras"' --cfg 'feature="peek-poke-derive"' -C metadata=89436a20db852f40 -C extra-filename=-89436a20db852f40 --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/debug/deps -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern euclid=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libeuclid-f1eedeec0010c47d.rlib --extern peek_poke=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libpeek_poke-5d628cb269347c01.rlib --extern peek_poke_derive=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libpeek_poke_derive-c36afb600719019a.so --deny warnings
[task 2020-01-28T21:45:55.244Z] error: unnecessary parentheses around type
[task 2020-01-28T21:45:55.244Z] --> peek-poke/tests/max_size.rs:55:17
[task 2020-01-28T21:45:55.244Z] |
[task 2020-01-28T21:45:55.245Z] 55 | assert_eq!(<(isize)>::max_size(), size_of::<isize>());
[task 2020-01-28T21:45:55.245Z] | ^^^^^^^ help: remove these parentheses
[task 2020-01-28T21:45:55.245Z] |
[task 2020-01-28T21:45:55.245Z] = note: -D unused-parens implied by -D warnings
[task 2020-01-28T21:45:55.245Z]
[task 2020-01-28T21:45:55.483Z] error: aborting due to previous error
[task 2020-01-28T21:45:55.483Z]
[task 2020-01-28T21:45:55.493Z] error: could not compile peek-poke.
[task 2020-01-28T21:45:55.493Z]
[task 2020-01-28T21:45:55.494Z] Caused by:
[task 2020-01-28T21:45:55.494Z] process didn't exit successfully: rustc --edition=2018 --crate-name max_size peek-poke/tests/max_size.rs --error-format=json --json=diagnostic-rendered-ansi --emit=dep-info,link -C debuginfo=2 --test --cfg 'feature="default"' --cfg 'feature="derive"' --cfg 'feature="euclid"' --cfg 'feature="extras"' --cfg 'feature="peek-poke-derive"' -C metadata=89436a20db852f40 -C extra-filename=-89436a20db852f40 --out-dir /builds/worker/checkouts/gecko/gfx/wr/target/debug/deps -C incremental=/builds/worker/checkouts/gecko/gfx/wr/target/debug/incremental -L dependency=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps --extern euclid=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libeuclid-f1eedeec0010c47d.rlib --extern peek_poke=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libpeek_poke-5d628cb269347c01.rlib --extern peek_poke_derive=/builds/worker/checkouts/gecko/gfx/wr/target/debug/deps/libpeek_poke_derive-c36afb600719019a.so --deny warnings (exit code: 1)
[task 2020-01-28T21:45:55.494Z] warning: build failed, waiting for other jobs to finish...
[task 2020-01-28T21:46:10.193Z] error: build failed
[fetches 2020-01-28T21:46:10.196Z] removing /builds/worker/fetches
[fetches 2020-01-28T21:46:11.649Z] finished
[taskcluster 2020-01-28 21:46:12.871Z] === Task Finished ===
[taskcluster 2020-01-28 21:46:12.871Z] Unsuccessful task run with exit code: 101 completed in 1182.452 seconds

Status: RESOLVED → REOPENED
Flags: needinfo?(cmanchester)
Resolution: FIXED → ---
Target Milestone: mozilla74 → ---

Well, 1.41 is out so we can just start working on that.

Flags: needinfo?(cmanchester)
Summary: Update builders to rustc 1.40 → Update builders to rustc 1.41
Depends on: 1612731
Attachment #9123005 - Attachment description: Bug 1605188 - Update builders to rustc 1.40 → Bug 1605188 - Update builders to rustc 1.41
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/802aa1e10c54
Update builders to rustc 1.41 r=firefox-build-system-reviewers,rstewart
https://hg.mozilla.org/integration/autoland/rev/1415d9d73a9b
Bump oom hook version for rustc 1.41.0. r=froydnj

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&searchStr=linux%2Cx64%2Copt%2Cvalgrind-linux64-valgrind%2Fopt%2C%28v%29&fromchange=ee582f48caa16183f496f63dfd85eefb288ba4fb&selectedJob=288421924

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=288421924&repo=autoland&lineNumber=56249

Backout link: https://hg.mozilla.org/integration/autoland/rev/a1499734a96e1e55f6396ac494404aaf6219aad3

[task 2020-02-11T23:18:00.396Z] 23:18:00 INFO - 0:04.21 --8294-- Reading syms from /usr/lib/x86_64-linux-gnu/libwayland-client.so.0.1.0
[task 2020-02-11T23:18:00.396Z] 23:18:00 INFO - 0:04.21 --8294-- Considering /usr/lib/debug/.build-id/bc/365fd67a9e7c5ce6a1f711e63cd313abca9312.debug ..
[task 2020-02-11T23:18:00.396Z] 23:18:00 INFO - 0:04.21 --8294-- .. build-id is valid
[task 2020-02-11T23:18:00.412Z] 23:18:00 INFO - 0:04.22 --8294-- Reading syms from /usr/lib/x86_64-linux-gnu/libxkbcommon.so.0.0.0
[task 2020-02-11T23:18:00.412Z] 23:18:00 INFO - 0:04.22 --8294-- object doesn't have a symbol table
[task 2020-02-11T23:18:00.419Z] 23:18:00 INFO - 0:04.23 --8294-- Reading syms from /usr/lib/x86_64-linux-gnu/libwayland-cursor.so.0.0.0
[task 2020-02-11T23:18:00.419Z] 23:18:00 INFO - 0:04.23 --8294-- Considering /usr/lib/debug/.build-id/ec/a7a8c0377270bef9bfb52f31ea1714b9052669.debug ..
[task 2020-02-11T23:18:00.419Z] 23:18:00 INFO - 0:04.23 --8294-- .. build-id is valid
[task 2020-02-11T23:18:01.004Z] 23:18:01 INFO - 0:04.81 TEST-PASS | valgrind-test | valgrind found no errors
[task 2020-02-11T23:18:01.004Z] 23:18:01 INFO - 0:04.81 TEST-UNEXPECTED-FAIL | valgrind-test | non-zero exit code from Valgrind: -139
[task 2020-02-11T23:18:01.383Z] 23:18:01 ERROR - Return code: 2
[task 2020-02-11T23:18:01.383Z] 23:18:01 WARNING - setting return code to 2
[task 2020-02-11T23:18:01.383Z] 23:18:01 FATAL - 'mach valgrind-test' did not run successfully. Please check log for errors.
[task 2020-02-11T23:18:01.383Z] 23:18:01 FATAL - Running post_fatal callback...
[task 2020-02-11T23:18:01.383Z] 23:18:01 FATAL - Exiting -1
[task 2020-02-11T23:18:01.383Z] 23:18:01 INFO - [mozharness: 2020-02-11 23:18:01.383923Z] Finished valgrind-test step (failed)
[task 2020-02-11T23:18:01.384Z] 23:18:01 INFO - Running post-run listener: _parse_build_tests_ccov
[task 2020-02-11T23:18:01.384Z] 23:18:01 INFO - Running command: ['/builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python', 'mach', 'python', 'testing/parse_build_tests_ccov.py'] in /builds/worker/workspace/build/src
[task 2020-02-11T23:18:01.384Z] 23:18:01 INFO - Copy/paste: /builds/worker/workspace/build/src/obj-x86_64-pc-linux-gnu/_virtualenvs/init/bin/python mach python testing/parse_build_tests_ccov.py
[task 2020-02-11T23:18:01.390Z] 23:18:01 INFO - Using env: {'DEBIAN_FRONTEND': 'noninteractive',

Flags: needinfo?(cmanchester)
Pushed by aciure@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36cf674d8e9d
Update builders to rustc 1.41 r=firefox-build-system-reviewers,rstewart
https://hg.mozilla.org/integration/autoland/rev/3777bd90a35a
Bump oom hook version for rustc 1.41.0. r=froydnj

Thanks for re-landing!

Flags: needinfo?(cmanchester)
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

Looks like a 1.41.1 release is around the corner: https://github.com/rust-lang/rust/pull/69359

Looks like tomorrow will be the release of Rust 1.41.1: https://github.com/rust-lang/rust/blob/stable/RELEASES.md

Don;'t know if it's of any benefit to FF but posting as an FYI.

Version 1.41.1 (2020-02-27)

Always check types of static items
Always check lifetime bounds of Copy impls
Fix miscompilation in callers of Layout::repeat

Filed bug 1618316 for the 1.41.1 release.

You need to log in before you can comment on or make changes to this bug.