Closed Bug 1606265 Opened 3 years ago Closed 3 years ago

Swap long press on new tab button to bring up containers menu for right click, and add left click option in preferences

Categories

(Firefox :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 74
Tracking Status
relnote-firefox --- -
firefox74 + fixed

People

(Reporter: kmwerts, Assigned: kmwerts, NeedInfo)

References

(Depends on 1 open bug)

Details

Attachments

(2 files)

Discussed with UX to change the long press on the new tab button to bring up the containers menu to be a right click.

We also discussed adding left click on the new tab button as a preference that can be enabled. Turns out this was already implemented (thanks!), so I'm adding the checkbox in the preferences menu.

Added right click on new tab button to open containers menu.
Removed long press and added option to enable left click in preferences menu.

Let me know if you think I should rename the longPressBehavior pref and/or change it's type to bool.

Copy for check box:
Select a container for each new tab

Alt text for + button:
Select container to open a new tab

@bryanbell - have you consulted with a11y on this yet? if not can you ask them to review the copy and alt text?

Flags: needinfo?(bbell)

(In reply to kendall from comment #3)

Let me know if you think I should rename the longPressBehavior pref and/or change it's type to bool.
Thanks Kendall for your work on this!

Yes we should change this pref name since long Press won't do anything anymore. For extra credit, we should also see if any addons are setting this pref and alert their users. It would also be nice if we can somehow alert MAC users of this change. Instead of filing a bug "long press isn't working anymore" and then learning that they need to right click instead.

For extra credit, we should also see if any addons are setting this pref and alert their users.

I think we're good there. This pref isn't exposed in the web extension API.

(In reply to Tanvi Vyas[:tanvi] from comment #5)

It would also be nice if we can somehow alert MAC users of this change. Instead of filing a bug "long press isn't working anymore" and then learning that they need to right click instead.

For this, we will have to change the onboarding panels. One of them discusses the long press. So we could release a new version the day 73/74 comes out with a new panel to explain, or can we send an email to the AMO users? Not sure what other options we have.

Do we need UX or Content help with this new panel? Is it a simple text change, or something more?

The onboarding panel is just a text change (but I would also argue that it may not be effective and someone might want to look at all of onboarding), but if we wanted a new panel to pop up for existing users, we might want some help with that.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4a6071f143a5
Work on new tab containers menu popup. r=fluent-reviewers,Gijs,flod
Regressions: 1611361
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 74
Regressions: 1611454
No longer regressions: 1611454

(In reply to kendall from comment #9)

The onboarding panel is just a text change (but I would also argue that it may not be effective and someone might want to look at all of onboarding), but if we wanted a new panel to pop up for existing users, we might want some help with that.

Folks who've been using this feature will think it just broke.
Can we trigger an instructive tooltip when the long press is triggered? Can be temporary, for one or two versions.

It's sad to see the old behavior gone as I find it easier to hold, move and release than right click, move and left click. Fortunately the left click pref can work like before (and I can middle click to open a tab without identity).

See Also: → 1612396

Folks who've been using this feature will think it just broke.

Yes, I was just about to report a bug, but mozregression told me about this change…

It's sad to see the old behavior gone as I find it easier to hold, move and release than right click

Yes, it's much easier (for me) to do the long press on the new tab button than a right click with the trackpad of the MacBook…

Fortunately the left click pref can work like before

How? I see the new option in the preferences but when enabled the containers popup appears even with a short press on the new tab button which is different than before and not usable for me because most times I don't want to open a container tab (but I still need a container tab a few times per day)…

How? I see the new option in the preferences but when enabled the containers popup appears even with a short press on the new tab button which is different than before and not usable for me because most times I don't want to open a container tab (but I still need a container tab a few times per day)…

Well, because I do not use the plus icon for regular tabs a lot (I use Ctrl-t and start typing). You can middle click for a regular tab but I find that it's not easy to adapt that new habit.

Currently the top post of the /r/firefox subreddit is a post advertising the long-press feature for container tabs.

https://www.reddit.com/r/firefox/comments/eyfhy6/til_if_you_press_and_hold_the_new_tab_button_it/

I draw attention to this to emphasize my point that simply changing this behavior without directly informing users who erroneously try to invoke the old behavior will lead to frustration. I know many are like me who have a tendency to ignore "What's new" style notifications when I opened the browser to do something else. This will seem broken to a lot of users.

Kendall, I think we should have an addition to our release notes addition for this feature change. Could you fill in the request please? Thanks
https://wiki.mozilla.org/Release_Management/Release_Notes#How_to_nominate_a_bug_for_release_notes_addition.3F

Flags: needinfo?(kwerts)

Release Note Request (optional, but appreciated)
[Why is this notable]:
[Affects Firefox for Android]: No
[Suggested wording]: A New Container Tab menu can now be opened with right click on the new tab button. In addition, an option to require a container tab to be selected when the new tab button is clicked is available.
[Links (documentation, blog post, etc)]:

relnote-firefox: --- → ?
Flags: needinfo?(kwerts)

Adding long press back. See bug 1613250

Note added to Nightly 74 release notes

Depends on: 1646985
Depends on: 1712840

I was assuming that "Select a container for each new tab" would somehow nag me more about opening things in containers and in the right containers. However, it doesn't affect middle-clicks on links nor opening new tabs with Ctrl+t (or Command+t).

You need to log in before you can comment on or make changes to this bug.