Closed Bug 1607667 Opened 5 months ago Closed 3 months ago

[css-images] Consider changing initial value of 'image-orientation' to from-image

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- wontfix
firefox76 --- fixed

People

(Reporter: mozilla-apprentice, Assigned: heycam)

References

(Regressed 1 open bug)

Details

(Keywords: dev-doc-needed, site-compat, Whiteboard: [layout:backlog:77])

Attachments

(2 files, 1 obsolete file)

A resolution was made for csswg-drafts/#3799.

[css-images] Consider changing initial value of 'image-orientation' to from-image

  • RESOLVED: Accept proposal with an added note current solution is experimental and may change

Discussion.

Chrome is shipping the change to make from-image the initial value in Chrome 81 https://twitter.com/argyleink/status/1214616780200562690 so now may be a good time for us to make that change too.

Priority: P3 → P2

Looks like WebKit also landed this change, three days ago: https://bugs.webkit.org/show_bug.cgi?id=89052

If we land this now, it will make it to Firefox 74 which is released on March 10. The Chrome 81 release is on March 17, so if we want to wait for Chrome's experience to see that this change is safe, we should hold off landing until 75.

Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/80d17e69d2a5
Change initial value of image-orientation to from-image. r=emilio
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75

Posted site compatibility note for web developers.

Keywords: site-compat
Regressions: 1616789
Regressions: 1619576
Attachment #9133063 - Attachment is obsolete: true
Whiteboard: [layout:backlog:77]
Depends on: 1634180
No longer depends on: 1634180
Regressed by: 1634180
No longer regressed by: 1634180
Regressions: 1634180
Blocks: COVID-19

It turned out Chrome 81 already shipped this change (and broke Slack) so there’s no reason for Mozilla to stop shipping. This rather needs to ride Firefox 77 along with other Exif-related changes (Bug 1566316, Bug 1616169, Bug 1616411, Bug 1630165).

No longer blocks: COVID-19
You need to log in before you can comment on or make changes to this bug.