Closed Bug 1610403 Opened 3 years ago Closed 1 year ago

Allow to submit a part of a stack as "wip"

Categories

(Conduit :: moz-phab, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mhentges, Assigned: glob)

References

Details

(Keywords: conduit-triaged)

Attachments

(1 file)

Disclaimer: I might be using moz-phab incorrectly.

To reproduce:

  1. Make a solid change, submit it with moz-phab
  2. The revision shows up in Phabricator. Assign reviewers, feel happy that you made a good patch
  3. Some time later, work on a new patch. This patch depends on the previous, stable patch that you just submitted above^. You want some feedback from your team on this patch, so you submit it to Phabricator with moz-phab --wip and link it to your teammates.
  4. The original patch at the bottom of the stack is marked as "changes planned", even though only the last patch is "wip".

Expected behaviour

  • The patch that I submitted with --wip should be marked as "changes planned".
  • The patches below this patch shouldn't be marked as "changes planned".

Switches in moz-phab are modifying the entire stack.
We could be detecting the WIP state from the commit title - "WIP " or `"WIP:".

Type: defect → enhancement
Keywords: conduit-triaged
Priority: -- → P3
Summary: Submitting a single patch as "wip" will make the entire stack "wip" → Allow to submit a single patch as "wip"
Summary: Allow to submit a single patch as "wip" → Allow to submit a part of a stack as "wip"
Assignee: nobody → glob

Might be good to look into standardizing the WIP flag -- e.g. if it commit message starts with WIP: as suggested, mark it is draft, or if either --wip is passed or a draft revision is detected during submit make sure to prepend the first line starts with WIP: if it's not already there.

(In reply to Zeid Zabaneh [:zeid] from comment #2)

Might be good to look into standardizing the WIP flag -- e.g. if it commit message starts with WIP: as suggested, mark it is draft, or if either --wip is passed or a draft revision is detected during submit make sure to prepend the first line starts with WIP: if it's not already there.

I like this idea, however updating the local commit description for any commit other than HEAD is an expensive operation that we should avoid if possible.

Prepending the commit description sent to Phabricator should be trivial.

Duplicate of this bug: 1620665
  • adds wip attribute to each commit in a stack
  • set wip if any of the following is true:
    • --wip command line argument provided
    • commit description starts with WIP:, WIP, or is just WIP
    • commit is lacking reviewers
  • prefix revision summary with WIP: for all WIP submissions
  • handle revision state transisions into and out of WIP
  • some minor UI changes
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Blocks: 1699704
Regressions: 1700485
Regressions: 1700712
See Also: → 1701722
Regressions: 1701722
See Also: 1701722
See Also: → 1702227
You need to log in before you can comment on or make changes to this bug.