Closed Bug 1610927 Opened 6 months ago Closed 6 months ago

With system dark theme the composer message header fields aren't dark

Categories

(Thunderbird :: Theme, task)

task
Not set
normal

Tracking

(thunderbird73 fixed)

RESOLVED FIXED
Thunderbird 74.0
Tracking Status
thunderbird73 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

References

Details

Attachments

(1 file)

When the dark the system theme is active and the default TB theme used, the composer message header fields have still a white background with white text.

This fixes the dark system theme issue.

Additionally I changed:

  • On Mac and Windows I made the field a bit less tall to look better with the other elements like menulists etc.
  • The pills "border" changed to 1px instead of 2px makes it look more like a normal border.
  • I changed the "error" and "warning" background colour to a non-transparent one to look better with the dark theme. In editing mode the text was almost unreadable because of the dark background.
  • The Cc, Bcc etc. buttons are looking now like the .extra-recipients-label button when hovering. Also the focus is more consistent. What do you think about this?
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9122463 - Flags: review?(alessandro)
Comment on attachment 9122463 [details] [diff] [review]
1610927-default-dark-theme-composer.patch

Review of attachment 9122463 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks.
Attachment #9122463 - Flags: review?(alessandro)
Attachment #9122463 - Flags: review+
Attachment #9122463 - Flags: approval-comm-beta?
Target Milestone: --- → Thunderbird 74.0

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/9f47750c11dc
Fix the new compose header appearance with the default dark theme and some style tweaks. r=aleca DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1611918
Attachment #9122463 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1610771
You need to log in before you can comment on or make changes to this bug.