If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Advanced management of outgoing SMTP servers is buggy

RESOLVED DUPLICATE of bug 96207

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED DUPLICATE of bug 96207
15 years ago
12 years ago

People

(Reporter: Benno Nieswand, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
The list of outgoing servers, when you click advanced on an account setting
produces random disorder and repetitions and duplicates. Selection frequently
doesn't work correctly. I have seen the list of smtp servers corrupted in the
prefs.js, but even if there everything seems okay, it doesn't work properly.
I have 4 smtp servers, 8 accounts and 5 ids. 
Also setting default smtpserver is dangerous, because most the time it will
corrupt the list of outgoing servers completely.

Comment 1

15 years ago
Please say what build you're using when reporting bugs..

for the record, seems to be working fine for me (cvs build from 20020805, linux)
Summary: managment of outgoing servers is totally buggy → Advanced managment of outgoing SMTP servers is buggy

Comment 2

15 years ago
I confirm a strange behavior on retail 1.0, Win2k (build 2002053012): in the
advanced management of smtp, I have 
 - duplicates (and when the default smtp is suplicated, you cannot delete
 - blank lines

It would not bother me, but sometimes I get smtp errors when sending mails,
which seem to be related.

I "clean" this all regularly (in the prefs.js), but still duplicated and blank
servers reappear after some time, however I don't change my account settings.
(Reporter)

Comment 3

15 years ago
This problem has been around for quite a while on Windows versions
from the time I started using it (version 0.98 until 1.1b)
(Reporter)

Comment 4

15 years ago
Even worse, adding an outgoing server leaves the whole preference dialog not
functioning any more. You have to cancel and call preferences again to work with it.

Comment 5

15 years ago
Duplicate SMTP servers may be dup of bug 96207
Blank line/empty entry is also reported in bug 159427 and bug 146488

Re. comment 4: OK button not working in advanced/edit was just fixed: bug 150471

Comment 6

15 years ago
I've got the same bug.
I'm using Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1b) Gecko/20020824 a
nightly build which I download on th 24th of August at 17 o'clock MET.
I'm using Windows ME on AMD Duron PC with 256 MB of RAM.
I also tried to create I new profile because I thought it was an error of the
profile, but it didn't help.

To Reproduce the Bug:
1. Create a brand new profile.
2. Create 3 email accounts with the wizzard wich are all using differt pop-servers
3. Look into the smtp-maniging dialog, there should be 3 smtp-servers, all the
same server where one is marked as standard.
4. Add a new smtp-server which is completley different.
5. Try to select a different smtp-server for one of the 3 mail acounts and
you'll find 4 blank entires in the combo-box where to select the smtp-server to
be used for the account.
mass re-assign.
Assignee: racham → sspitzer

Comment 8

15 years ago
We had a change in our server design, bought a verisign certificate. Thus we 
had to use a new smtp server. We added the new server in Advanced Outgoing 
Server options, and set it as default. But MOZILLA STILL USED THE OLD ONE. I'm 
using Mozilla 1.4 [ Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) 
Gecko/20030612 ]

I tested this on serveral of our computers.

Plese fix this ASAP

 - hal

Comment 9

14 years ago
I experienced the failure of the advanced outgoing SMTP. Once you delete the old
-default- server, the one which is shown as default will be used, then you can
add the old one. 

Comment 10

14 years ago
I also encountered this problem on thunderbird 0.3 for Windows version.
I've two smtp servers in the account setting.  I just can not change the other
as the default smtp server.  This bug has a long history.  I've been hoping this
bug being fixed since thunderbird 0.1, but disappointed.

Comment 11

13 years ago
I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616; 
recently upgraded from 1.4. The Advanced dialog does not allow the addition of
SMTP servers. The New Account wizard also does not allow the addition of an SMTP
server; it refers one the the Account Settings dialog, which does not work. So,
there is no way to add an additional SMTP server.
Product: Browser → Seamonkey
(In reply to comment #0)
> produces random disorder and repetitions and duplicates.
(1) "repetitions and duplicates" problem is Bug 96207 and is already FIXED.
    See Bug 119609 Comment #24 for recovery of already defined duplicate entries.
(2) "random disorder" problem even after Bug 96207 is Bug 202045.
 
> Selection frequently doesn't work correctly.
By fixing Bug 96207, many problems in SMTP server definition/SMTP choice are
already resolved, although manual recovery is required form duplicate entries.
See Bug 119609.

(In reply to comment #11)
> The New Account wizard also does not allow the addition of an SMTP server
This is a result of fixing Bug 96207 (design change). 
See Bug 202468 for improvement of unkind SMTP related UI.
> The Advanced dialog does not allow the addition of SMTP servers.
> So, there is no way to add an additional SMTP server.
Read thru next FAQ.
http://kb.mozillazine.org/index.phtml?title=Thunderbird_:_FAQs_:_Multiple_SMTP_Servers
Don't confuse SMTP choice in "Server Settings"/Advanced of accounts and SMTP
definition in "Outgoing Server"/Advanced.

Anyway, problems caused "buggy"(this bug's issue) are already resolved by fixing
Bug 96207.
So this bug is to be closed as DUP of Bug 96207.
Problems even after fixing Bug 96207 should be processed by other bug(s) or new bug.
To all of bug reporter and comment posters:
   Does your problem still remain? 
   If yes, what still doesn't work correctly on current Mozilla or Thunderbird?

Updated

13 years ago
Assignee: sspitzer → mail

Comment 13

12 years ago
Old bug, no further responses. With trunk builds/SeaMonkey all seems to work now.

*** This bug has been marked as a duplicate of 96207 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Summary: Advanced managment of outgoing SMTP servers is buggy → Advanced management of outgoing SMTP servers is buggy
You need to log in before you can comment on or make changes to this bug.