Closed Bug 1611332 Opened 1 month ago Closed 9 days ago

Trigger media session's action handlers by media control keys

Categories

(Core :: Audio/Video: Playback, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: alwu, Assigned: alwu)

References

(Blocks 2 open bugs)

Details

Attachments

(7 files)

In this bug, we would connect the implementation of media control with the media session, then when pressing media control keys, it can trigger corresponding media session's action handlers.

That includes
(1) select globally active media session among tabs
(2) select active media session within a tab
(3) dispatch media control key events to correct handler

Duplicate of this bug: 1599591
Duplicate of this bug: 1592454
Duplicate of this bug: 1592151
Blocks: 1611328

According the discussion in berlin allhands, change this bug to P1 to indicate that I'm currently working on it.

Priority: P2 → P1

Target on next release version, mark it as P3.

Priority: P1 → P3
Blocks: 1614457
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dc80e2e315bb
part1 : implement MediaMetadataBase. r=chunmin
https://hg.mozilla.org/integration/autoland/rev/d9c81e130d8e
part2 : implement MediaSessionController which is used to update media session and store media metadata. r=chunmin
https://hg.mozilla.org/integration/autoland/rev/e84b9499917e
part3 : notify media session being created and destroyed. r=chunmin,bzbarsky
https://hg.mozilla.org/integration/autoland/rev/f68e07f10eff
part4 : directly notify context where media session exists if we have active media session. r=chunmin,bzbarsky
https://hg.mozilla.org/integration/autoland/rev/81962e36e851
part5 : add test for triggering media session's action handlers. r=chunmin
https://hg.mozilla.org/integration/autoland/rev/dc190b263fc7
part6 : add test for active media session. r=chunmin
https://hg.mozilla.org/integration/autoland/rev/02f224473690
part7 : add test for checking active session among tabs. r=bzbarsky
You need to log in before you can comment on or make changes to this bug.