Closed Bug 1617290 Opened 3 years ago Closed 2 years ago

KDE Neon User Edition: right click causes instant click in context menu

Categories

(Core :: Widget: Gtk, defect, P2)

74 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1552128

People

(Reporter: madLyfe, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Attached video Peek+2020-02-21+15-47.webm (obsolete) —

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

in KDE Neon(plasma version 5.18.1) with titlebars disabled, right click anywhere on page. its more apparent if you select some text element and then right click to get context menu.

Actual results:

what happens is the context menu appears and whatever is under the cursor at that moment is clicked. if you selected text and right clicked it would click "select all" instantly.

if you right click but dont let go it looks like you can bypass the "phantom" click.

Expected results:

no click events should trigger when right click context menu appears.

See Also: → 1457309

seems like adding back the titlebar fixes it. just adding another video of the issue with all addons disabled as well.

Attachment #9128258 - Attachment is obsolete: true
Blocks: gtktitlebar
Priority: -- → P2

Can you please test latest nightly or Firefox 76? I can't reproduce with plasma 5.18.4 / FF 75.

Flags: needinfo?(madLyfe)

(In reply to Martin Stránský [:stransky] from comment #2)

Can you please test latest nightly or Firefox 76? I can't reproduce with plasma 5.18.4 / FF 75.

im on 76.0b8 developer edition but its been a thing for me on 75 and maybe 74 iirc.

Flags: needinfo?(madLyfe)

And which distro is that? I can't reproduce it on Fedora 32.

Flags: needinfo?(madLyfe)

(In reply to Martin Stránský [:stransky] from comment #4)

And which distro is that? I can't reproduce it on Fedora 32.

KDE Neon User Edition all updates applied. using the ff dev ed installed via the ubuntu make method outlined here: https://askubuntu.com/a/548005/868274

Flags: needinfo?(madLyfe)
Summary: right click causes instant click in context menu → KDE Neon User Edition: right click causes instant click in context menu

I downloaded neon user edition live image (https://neon.kde.org/download) and tested that under VM. Installer crashed so I tested the live image only but it seems to work as expected. Disabled titlebar, browser restart, created new windows...all menus are in place.
So can you check your regular Firefox 76 there?
Thanks.

Flags: needinfo?(madLyfe)

I am also affected by this bug, it is present in xubuntu at least since version 18.04. Currently I am using xubuntu 20.04 with Firefox 76.0.1 and this bug appears after I disable the titlebar, resize the window and restart Firefox. If Firefox starts and I right-click on links or pictures, the menu is misplaced, like it is shown in the video. After resizing the window Firefox behaves normally, until the next start. This bug doesn't appear if the window is maximized, only if the window is resized to a smaller size before closing , then it is present on the next start.

I was able to reproduce this behaviour with the neon user edition live image in VirtualBox and a fresh install of xubuntu 20.04, also in VirtualBox.

Two Haswell systems, one with optimus, one without, both runnig xubuntu 20.04, are affected as well.

And I can confirm, that adding the titelbar back solves the misplacement and that is the default setting in xubuntu.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(madLyfe)
Resolution: --- → DUPLICATE
Duplicate of bug: 1552128
You need to log in before you can comment on or make changes to this bug.