Closed Bug 1618287 Opened 8 months ago Closed 5 months ago

[rel=preload] Write `PreloaderBase` class representing a preload

Categories

(Core :: Networking, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: mayhemer, Assigned: mayhemer)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-triaged])

Attachments

(1 file)

Part of Design documentation for rel=preload

Please follow the PreloaderBase class design notes.

The class is intended to be derived from and then registered in dom::Document.PreloadService under a key. Main usage is by resource loaders (script, style, ...) and is a basic coalescing block for the new preload implementation in DOM.

There is no need to implement the "use timeout" mechanism in this bug, specifically the two NotifyOpen and NotifyUsage methods, there is bug 1618921 filed for that.

Blocks: 1618289
Blocks: 1603542
Blocks: 1618921
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Component: DOM: Core & HTML → Networking
Priority: -- → P1
Whiteboard: [necko-triaged]
Depends on: 1631863
Blocks: 1636106
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Regressions: 1637888
You need to log in before you can comment on or make changes to this bug.