Closed Bug 1618536 Opened 1 year ago Closed 11 months ago

[rel=preload] as="font" preload support

Categories

(Core :: DOM: Core & HTML, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: mayhemer, Assigned: mayhemer)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Part of Design documentation for rel=preload

Please see the implementation notes for “font” type.

Tentatively depends on the fetch preloader, we need to consult a DOM peer before we decide how to write this.

Summary: [rel=preload] as="fetch" preload support → [rel=preload] as="font" preload support
Duplicate of this bug: 1600117
Assignee: nobody → honzab.moz
Status: NEW → ASSIGNED
Priority: -- → P1

Depends on D69628

Pushed by honzab.moz@firemni.cz:
https://hg.mozilla.org/integration/autoland/rev/2af03857e087
Introduce nsIContentPolicy::TYPE_INTERNAL_FONT_PRELOAD representing preload of font, mapping to TYPE_FONT externally, r=baku
https://hg.mozilla.org/integration/autoland/rev/e7c7716689d6
Preload for fonts, r=heycam,hsivonen
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
You need to log in before you can comment on or make changes to this bug.