Closed Bug 1619475 Opened 9 months ago Closed 9 months ago

Partial conversion of js/src test suites to Python 3

Categories

(Core :: JavaScript Engine, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla75
Tracking Status
firefox75 --- fixed

People

(Reporter: sfink, Assigned: sfink)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

I recently upgraded to Fedora 31, which ships a Python 3 in /usr/bin/python. Which means that I error out whenever I run the shell tests.

We seem to have a cluster of partially-completed bugs that convert parts of things. I didn't see (or remember) those before I dove in and fixed things up enough so I could run the subsets of jstests and jit-tests that I normally use.

I figure it's worth landing my fixes and cleaning up the rest eventually.

This fixes all of the jit-test problems I encountered, and fixes all but the wpt portion of jstests. This is unnecessary, but it also ports jstests from optparse to argparse (because optparse is deprecated, because I like argparse better, and because it happened to fix the minor compatibility issue I ran into even though it has a trivial fix on its own.)

Assignee: nobody → sphink
Status: NEW → ASSIGNED
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/057d1d3a9ed1
partial Python 3 compatibility for jit-tests and jstests r=arai
https://hg.mozilla.org/integration/autoland/rev/efb82594b292
also convert jstests from optparse to argparse r=arai

Comment on attachment 9130891 [details]
Bug 1619475 - also convert jstests from optparse to argparse

Revision D65400 was moved to bug 1609208. Setting attachment 9130891 [details] to obsolete.

Attachment #9130891 - Attachment is obsolete: true
Attachment #9130891 - Attachment is obsolete: false
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c753faaef709
partial Python 3 compatibility for jit-tests and jstests r=arai
https://hg.mozilla.org/integration/autoland/rev/eb037e72681e
also convert jstests from optparse to argparse r=arai
Flags: needinfo?(sphink)
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla75
Regressions: 1620846
Regressions: 1621187
Regressions: 1621193
You need to log in before you can comment on or make changes to this bug.