If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

focus is not urlbar for new, blank tabs

VERIFIED FIXED

Status

Camino Graveyard
Accessibility
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Simon Fraser)

Tracking

({regression})

Details

(Reporter)

Description

15 years ago
found using 2002.08.09.05 chimera bits. couldn't find an existing bug for this,
so pls dup or reassign as needed.

0. make sure your pref for new tabs is set to open blank tabs (not your home page).
1. open a new tab (cmd-T or File > New Tab).
2. try typing a url in the new tab.

expected: focus should be in the urlbar for new tabs which are blank, so should
be able to type immediately without having to mouseclick into the urlbar.

actual results: not sure where focus is, but it's not in the urlbar (typing does
nothing). need to mouseclick into the urlbar first, before typing (hitting tab
key doesn't focus either).
(Reporter)

Comment 1

15 years ago
drat, i missed 162000.

anyhow, i'll see if when this regressed...

side note: this doesn't affect new, blank browser windows (if your pref is set
to open blank new windows).
Keywords: regression
(Reporter)

Updated

15 years ago
QA Contact: winnie → sairuh
(Reporter)

Comment 2

15 years ago
this regressed btwn the 2002.08.02.05 (fine) and 2002.08.03.05 (broken) chimera
builds.

Comment 3

15 years ago
*** Bug 161870 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 162130 has been marked as a duplicate of this bug. ***
bryner was last playing with this
Assignee: pinkerton → bryner
(Reporter)

Updated

15 years ago
Blocks: 147975

Comment 6

15 years ago
*** Bug 163200 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

15 years ago
Component: General → Accessibility
(Assignee)

Comment 7

15 years ago
Taking
Assignee: bryner → sfraser
(Assignee)

Comment 8

15 years ago
Mine. I made [BWC focusURLBar] do a setActive:NO on the content area, and now
explicitly focus the URL bar for new tabs which load about:blank. Both were
necessary.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 9

15 years ago
*** Bug 163985 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

15 years ago
vrfy'd fixed using 2002.08.26.05.
Status: RESOLVED → VERIFIED

Updated

15 years ago
No longer blocks: 147975
You need to log in before you can comment on or make changes to this bug.