Closed Bug 1620048 Opened 4 months ago Closed 4 months ago

"There are no downloads." text in about:downloads is pretty much unreadable - should use photon colours

Categories

(Firefox :: Downloads Panel, defect, P3)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- verified
firefox76 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

(Regression)

Details

(Keywords: access, regression)

Attachments

(2 files)

Tested on macOS nightly in case it matters.

The text is grey, and so is the background. The text is also tiny.

I have to assume this regressed at some point, it seems unlikely we shipped it with contrast this low.

Flags: needinfo?(gijskruitbosch+bugs)

Results from mozregression:
9:54.72 INFO: Got as far as we can go bisecting nightlies...
9:54.72 INFO: Last good revision: 8ec327de0ba7c25c185b887a57877657bda20d47 (2019-01-14)
9:54.72 INFO: First bad revision: 2bf2c209f520c75405b70ed5a5a12c2a8938dffe (2019-01-15)
9:54.72 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8ec327de0ba7c25c185b887a57877657bda20d47&tochange=2bf2c209f520c75405b70ed5a5a12c2a8938dffe

Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → macOS
Hardware: Unspecified → Desktop

This is a bit better on Windows, but we technically fail contrast checks there, too.

I also noticed that drag/drop on this text is supposed to work (bug 978291) but AFAICT drag/drop even to a populated downloads list box is also broken. I filed bug 1620184.

From the regression window, this looks like bug 1511878.

Flags: needinfo?(gijskruitbosch+bugs)
Regressed by: 1511878

Looks like the colour should be var(--in-content-deemphasized-text).

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Priority: -- → P3
Summary: "There are no downloads." text in about:downloads is pretty much unreadable → "There are no downloads." text in about:downloads is pretty much unreadable - should use photon colours
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/20e437df546f
use photon de-emphasized text colour for about:downloads de-emphasized text, r=mak
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

Should this have a Beta uplift request?

Flags: needinfo?(gijskruitbosch+bugs)

Comment on attachment 9132012 [details]
Bug 1620048 - use photon de-emphasized text colour for about:downloads de-emphasized text, r?mak

Beta/Release Uplift Approval Request

  • User impact if declined: Unreadable text on macOS
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial CSS change to make the foreground colour suck less
  • String changes made/needed: nope
Flags: needinfo?(gijskruitbosch+bugs)
Attachment #9132012 - Flags: approval-mozilla-beta?

Comment on attachment 9132012 [details]
Bug 1620048 - use photon de-emphasized text colour for about:downloads de-emphasized text, r?mak

Low risk css change, uplift approved for 75 beta 6, thanks!

Attachment #9132012 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced the initial issue in Release version 74 using Windows 10.
Verified - Fixed in latest Nightly build 76.0a1 and Firefox Beta 75.0b7 using Windows 10 and MacOS 10.15.

Flags: qe-verify+
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
See Also: → 1628528
You need to log in before you can comment on or make changes to this bug.