Closed Bug 1623265 Opened 5 months ago Closed 5 months ago

Stop disabling / enable hardware acceleration (HWA)

Categories

(Thunderbird :: Preferences, enhancement)

enhancement
Not set
normal

Tracking

(thunderbird75 fixed)

RESOLVED FIXED
Thunderbird 76.0
Tracking Status
thunderbird75 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

In 2015 hardware acceleration was disabled by default due to a large number of problems. See bug 1131879. With a change made in bug 1619032, our non-standard HWA preferences are causing a problem with a test.

I think we should stop disabling this by default and see if the problems remain.

I recently started looking at this area myself. Took it a step further and enabled webrender in several of my Firefox and Thunderbird instances - NTF so far.

Agreed - let's give it a couple weeks on nightly.

See Also: → 1619032

I did a Try run with these changes and they do fix the current test failure without introducing new failures. No real surprise there.

Attachment #9134070 - Flags: review?(mkmelin+mozilla)

The reason I started looking at this is Bug 1381485 - Hangs sending mail while copying message to Sent folder on Mac-only while displaying the progress bar. Deadlock in graphics on CGLClearDrawable.

Component: General → Preferences
Summary: Stop disabling hardware acceleration → Stop disabling / enable hardware acceleration (HWA)
See Also: 16190321381485
Comment on attachment 9134070 [details] [diff] [review]
1623265-enable-hwa-1.diff

Review of attachment 9134070 [details] [diff] [review]:
-----------------------------------------------------------------

Let's do it.
Attachment #9134070 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → Thunderbird 76.0

as a minor data point, I enabled HWA via Prefs, for Daily, on MacOS 10.14.6 a month or two ago: no trouble so far.

Pushed by benc@thunderbird.net:
https://hg.mozilla.org/comm-central/rev/18828895ee5d
Stop disabling hardware acceleration. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Comment on attachment 9134070 [details] [diff] [review]
1623265-enable-hwa-1.diff

I'd be more comfortable taking this in 75.0b3 which will have much fewer changes than the upcoming 76.0b1.  In part because it will be much easier to determine whether user problem reports are caused by HWA vs 500 other patches in 76. 

If anyone has concerns, speak up before we build the beta.   I'm feeling good about Mac users. But I am wary for Windows users for  which this was disabled in  bug 1131879 - we should be prepared to quickly back it out for Windows users (or Mac users) if problem reports come in.
Attachment #9134070 - Flags: approval-comm-beta+

No ill effects have been reported thus far, so I am feeling good about taking this on ESR. Looking forward to mitigating the effects of bug 1381485.
If you agree, please nominate.

Flags: needinfo?(geoff)

Based on emails in tb-drivers, backing off enabling HWA for 68

Flags: needinfo?(geoff)
You need to log in before you can comment on or make changes to this bug.