Closed Bug 1624713 Opened 1 year ago Closed 1 year ago

Convert editBookmarkOverlay.dtd to fluent

Categories

(Firefox :: Bookmarks & History, task, P1)

task

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox76 --- wontfix
firefox77 --- verified

People

(Reporter: Gijs, Assigned: salniker, Mentored)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

There are some 20-ish strings here:

browser/locales/en-US/chrome/browser/places/editBookmarkOverlay.dtd

They are used exclusively from https://searchfox.org/mozilla-central/source/browser/components/places/content/editBookmarkPanel.inc.xhtml

The new ftl should live in https://searchfox.org/mozilla-central/source/browser/locales/en-US/browser/ .

The included .xhtml content gets used in 3 places, see https://searchfox.org/mozilla-central/search?q=editbookmarkpanel.inc.&case=false&regexp=false&path=

In all except browser-doctype.inc, these can just be added as regular .ftl links in the files that are including the .inc.xhtml file.

In the browser-doctype case, it should be possible to remove the DTD reference, and then use MozXULElement.insertFTLIfNeeded() to insert the .ftl from https://searchfox.org/mozilla-central/rev/c80fa7258c935223fe319c5345b58eae85d4c6ae/browser/base/content/browser-places.js#306 , without adding it as a fixed .ftl link in browser.xhtml. We should check if this works correctly and doesn't leave warnings in the browser console. I think it will, but if not, I guess we should add the new .ftl in browser.xhtml after all.

To test this, simply load any page and click the star button in the address bar (or hit the shortcut - cmd-D on mac, ctrl-D on Windows).

Mentor: mconley, gijskruitbosch+bugs
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/49509cff8c94
Convert editBookmarkOverlay.dtd to fluent r=Gijs,fluent-reviewers,flod
Depends on: 1625333

I filed a bug to unblock this landing; I don't think it's anything to do with the contents of the patch.

Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a2aecef76edd
Convert editBookmarkOverlay.dtd to fluent r=Gijs,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
Duplicate of this bug: 1609554
No longer depends on: 1632056
Regressions: 1632056

Verified fixed as part of PI 551; tested with Nightly 77 across platforms (Windows 10, macOS 10.15 and Ubuntu 18.04).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.