Closed Bug 1627961 Opened 1 year ago Closed 5 months ago

DevTools panel tooltips appear with no background when widget.disable-native-theme-for-content is true

Categories

(Core :: Widget, defect)

Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1691428
Tracking Status
firefox87 --- ?

People

(Reporter: ntim, Unassigned)

References

Details

(Whiteboard: [not-a-fission-bug])

Attachments

(1 file)

Attached image Screenshot
No description provided.
Summary: Tooltips appear with no background on the web console settings menu → Tooltips appear with no background on the web console and accessibility inspector settings menu

The priority flag is not set for this bug.
:Honza, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)

I can't reproduce this problem on Win10
Tim, what OS you you using?

Honza

Flags: needinfo?(odvarko) → needinfo?(ntim.bugs)

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #2)

I can't reproduce this problem on Win10
Tim, what OS you you using?

This is macOS.

Flags: needinfo?(ntim.bugs)

The priority flag is not set for this bug.
:Honza, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)

Nicolas, can you reproduce this on Mac?

Honza

Flags: needinfo?(odvarko) → needinfo?(nchevobbe)

no I can't.
Tim do you have specific pref turned on? (like things for WebRender ?)

Flags: needinfo?(nchevobbe) → needinfo?(ntim.bugs)

(In reply to Nicolas Chevobbe [:nchevobbe] from comment #6)

no I can't.
Tim do you have specific pref turned on? (like things for WebRender ?)

Nothing that stands out to me in about:support.

Flags: needinfo?(ntim.bugs)

Note that it only happens in the tooltips of the menu items.

The priority flag is not set for this bug.
:Honza, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)

Tim, is this reproducible in a new fresh Firefox profile?

Honza

I can't reproduce this.

Tim, please feel free to reopen if you still see it.

Honza

Status: NEW → RESOLVED
Closed: 1 year ago
Flags: needinfo?(odvarko)
Resolution: --- → WORKSFORME

I'll look again when I'll have time to update Nightly.

Flags: needinfo?(ntim.bugs)

This is still reproducible, but I found out this is due to widget.disable-native-theme-for-content being set to true.

Status: RESOLVED → REOPENED
Component: Shared Components → Widget
Flags: needinfo?(ntim.bugs)
Product: DevTools → Core
Resolution: WORKSFORME → ---
Summary: Tooltips appear with no background on the web console and accessibility inspector settings menu → Tooltips appear with no background in panels when widget.disable-native-theme-for-content is true
Summary: Tooltips appear with no background in panels when widget.disable-native-theme-for-content is true → DevTools panel tooltips appear with no background when widget.disable-native-theme-for-content is true
Status: REOPENED → NEW

This tooltip is a XUL tooltip element in a non-chrome document. It is inside the devtools-toolbox document, at window > #toolbox-container > #aHTMLTooltip. The tooltip has -moz-default-appearance: tooltip and no background-color. The toolbox document uses the basic theme, and the basic theme does not support StyleAppearance::Tooltip, so we don't render a background.

As a solution, I think it would make sense to use the regular native theme (not the basic theme) for the toolbox document. If it uses XUL elements such as tooltips and panels, it is really built to be used in combination with the regular native theme.
I don't know what's a good way to differentiate the devtools toolbox document from, say, about:support (which probably should use the basic theme).

Tracking non-native theming bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7

Only Linux NNT is a Fission blocker and this is not marked as a linux-nnt blocker so removing the Fission milestone here. If this turns out to be required for Linux-NNT, please add Fission Milestone ? to add it back to Fission triage. Thanks!

Fission Milestone: M7 → ---

Tim, can you still reproduce this bug?

I tested Fx87 Nightly on macOS and Windows 10 with widget.disable-native-theme-for-content and I can't reproduce. Maybe this is related to some dark mode theme or setting you have enabled? I have OS dark mode enabled on both macOS and Windows 10, but my devtools UI isn't black like yours.

If this bug only affects macOS, then it doesn't need to block Fission MVP.

Flags: needinfo?(ntim.bugs)
OS: Unspecified → macOS
Whiteboard: [fission-]

I can still reproduce with the web console tooltips (notably the ones from the original screenshot), or any tooltips from the settings arrow-style panels in devtools really.

Flags: needinfo?(ntim.bugs)

Not a Fission bug

Whiteboard: [fission-] → [not-a-fission-bug]

Something similar happens with the context menu in the sidebar of the Storage panel. Hovering over context menu items does not show a blue background.

Status: NEW → RESOLVED
Closed: 1 year ago5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1691428

This bug was closed as a duplicate of bug 1691428, which fixed a bug on Linux but I can still reproduce this bug's devtools tooltips bug on macOS. Should the fix for bug 1691428 also have fixed macOS? Or will "devtools should use native theme" bug 1692306 fix this bug?

Flags: needinfo?(emilio)

This was actually fixed in bug 1696988

Flags: needinfo?(emilio)
You need to log in before you can comment on or make changes to this bug.