Closed Bug 1630362 Opened 3 months ago Closed 2 months ago

Ply3 generates idpl_yacctab.py and ipdl_lextab.py in the srcdir

Categories

(Firefox Build System :: General, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1633156

People

(Reporter: KrisWright, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

Previously, Bug 528367 generated ipdl_yacctab.py and ipdl_lextab.py in the objdir. When we updated to ply 3.10 in Bug 1621359 it started generating these files in the srcdir again. This needs to be updated so they generate in the right place.

Priority: -- → P3

Having extra stuff in the build dir is kind of annoying. If it isn't easy to fix, maybe these files could be added to the hgignore and gitignore files? Though I guess that will not fix the problem that clobbering won't necessarily rebuild these files.

Blocks: mach-busted

This is still annoying me. Can we at least do what Andrew suggested in the previous comment?

Flags: needinfo?(kwright)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1633156

(In reply to Tom Schuster [:evilpie] from comment #3)

This is still annoying me. Can we at least do what Andrew suggested in the previous comment?

This should have been fixed with ply not generating cache table files anymore, but you may have to rm the actual cache table files from your directory.

Flags: needinfo?(kwright)

Yeah, if you rm the files now (assuming you're at a remotely current version of mozilla-central you shouldn't see this any more.

Great. It would have been good if an announcement had been made about that somewhere, as I'd been staring at those files for quite a while now. I made a post to dev-platform just now about it.

You need to log in before you can comment on or make changes to this bug.