Closed Bug 1633287 Opened 1 year ago Closed 1 year ago

Backspace and navigation keys no longer working for recipient input fields

Categories

(Thunderbird :: Message Compose Window, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 77.0

People

(Reporter: thomas8, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Seen on 77.0a1 (2020-04-26) (64-bit), Win10

Weird and nasty, if someone is able to reproduce this, please confirm!

STR

  1. compose, start recipient input for "john"
  2. backspace to remove autocomplete suggestion or to correct to "Jane"
  3. press any navigation keys to move cursor (cursor left, home, etc.)

Actual result

  • backspace does nothing
  • navigation keys do nothing

Expected

  • remove inline autocomplete suggestion (which is selected)
  • then remove last typed character
  • maybe both of the above in one go (so as to remove the last typed character immediately)
  • for navigation keys, move cursor within input text

This is a regression, probably related to the changes of autocomplete to keydown

No longer depends on: 1627520
Regressed by: 1627520
Component: Composition → Message Compose Window
Product: MailNews Core → Thunderbird
Duplicate of this bug: 1632494
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Priority: -- → P1

Silly mistake of preventing the default event when the input is not empty.
Sorry about that.

Attachment #9143706 - Flags: review?(mkmelin+mozilla)
Attachment #9143706 - Flags: feedback?(bugzilla2007)
Attachment #9143706 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → Thunderbird 77.0
Comment on attachment 9143706 [details] [diff] [review]
1633287-input-field.diff

Review of attachment 9143706 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, thanks, this fixes the problem.
There's a similar thing about Ctrl+A which also double-fires now, selecting all pills in all addressing rows prematurely (instead of starting with all pills in current row).
Attachment #9143706 - Flags: feedback?(bugzilla2007) → feedback+

Thanks Thomas.
Can you file a bug for it and assign it to me? I'll take care of it right away.

(In reply to Alessandro Castellani (:aleca) from comment #4)

Thanks Thomas.
Can you file a bug for it and assign it to me? I'll take care of it right away.

Of course: Bug 1633562. I love that energy!

Regressed by: 1630765
No longer regressed by: 1627520

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/8f494764f440
Fix backspace and navigation keys issue on recipient input fields. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.