Closed Bug 1634920 Opened 1 year ago Closed 8 months ago

White line in bottom right of the screen when using fullscreen video playback on macOS (OpenGL backend)

Categories

(Core :: Graphics, defect)

x86_64
macOS
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix

People

(Reporter: cheapgood, Unassigned)

References

(Blocks 1 open bug)

Details

(4 keywords)

Attachments

(3 files)

Attached image Green Line Bottom Right

I noticed that streaming videos in full screen will introduce a graphical bug on the bottom right of the video's playing area on Mac. This seems to have started around Firefox 72. I tried a copy of Firefox 61 again and I don't experience this issue.

Example:

  1. Play this video on youtube (https://youtu.be/OqqKV7m0Zy4?t=49) and go full screen.
  2. Do Not Move the Mouse. Video playback controls hide this issue.
  3. At 1:02, the video will go all gray and you should be able to see the line below the video like I attached.

Note: Not sure if important but if youtube's playback controls load, the graphical bug may shift position/colors based on when in the video the playback controls hid themselves again.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Audio/Video: Playback
Product: Firefox → Core
Component: Audio/Video: Playback → Graphics

Can you attach the contents of your about:support as a text file?

Flags: needinfo?(cheapgood)

Should I actually close this ticket? I can't actually reproduce the issue anymore. I've rebooted my mac laptop before and still had the video glitch. But when my laptop hard crashed, the video glitch disappeared.

Flags: needinfo?(cheapgood) → needinfo?(jbonisteel)

Please open about:support, click on "Copy text to clipboard" and paste it here. It may contain crash reports or other hints about what it might have been.

Attached file about:support output

Was it Firefox that crashed or your laptop itself? When you go to about:crashes in your browser is there anything there?

Flags: needinfo?(jbonisteel)
Severity: -- → S3

about:crashes says "No crash reports have been submitted." I think it's empty because I uninstalled and re-installed Firefox.

I would not say that it was Firefox that crashed my laptop directly. I think it is indirect because the WindowServer process consumed over >2 GB of RAM when my laptop crashed. I decided to finish the Hulu video I had open in Safari before rebooting. The laptop crashed after I quit Firefox (full Command+Q to quit) and before the video started playing again.

I don't know why the crash fixed the underline I had in videos but rebooting and doing a Command+Q before wouldn't fix it so I decided to file this bug report. Maybe important detail but when I tried safe mode, the underline that was in my screenshot would not show when I tried playing the same video.

Duplicate of this bug: 1643484
Duplicate of this bug: 1649825

Unsure if related: bug 1403085 added a full-screen-api.macos-native-full-screen pref in 70.

Summary: Fullscreen Video Playback Introduces Graphical Issue in Bottom Right of Screen → regression: White line in bottom right of the screen when using fullscreen video playback on macOS
Duplicate of this bug: 1686908

Hey Jim, pinging since this is still taking place and since triage owners have changed since this originally came up. Wanting to make sure it's on your radar and triaged appropriately. Thanks.

Flags: needinfo?(jmathies)

From the bug 1686908, simmilar problem is happening at M1 Macbook Air, but happening on Zoomed mode, not the fullscreen mode.

My M1 Mac is having problem on zoomed mode(not fullscreen) and so the original issue of this is not affected to my macbook.
and, my M1 having issue with the left side of the video.

The problem of pixels is affected by the video playback's color.
When at the video if it was full green and video has changed to full yellow, when after changing yellow you could see the line of pixels are still green.

This thing : Do Not Move the Mouse. Video playback controls hide this issue. still happens, but only if it is on video playback area.
You could move your mouse whereever you want, but only not video playback area.

If you see the attached file that I've attached, it could be a bit hard but anyway can see the problem.

It could be hard to see, so on the previous that I've reported, have attached why it could be a problem
https://bug1686908.bmoattachments.org/attachment.cgi?id=9197269

on that image, you could see it even on Camera.
Because "The problem of pixels is affected by the video playback's color." this is happening.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jmathies)
Keywords: polish
Blocks: gfx-triage
Summary: regression: White line in bottom right of the screen when using fullscreen video playback on macOS → White line in bottom right of the screen when using fullscreen video playback on macOS (OpenGL backend)

Curious why we are not getting webrender here.

edit - because we hadn't shipped yet.

Not able to reproduce, lets see if QA can help find a regression range.

QA Whiteboard: [qa-regression-triage]

Hello!
We tried several times to reproduce the issue on M1 Mac mini (Big Sur 11.1) with Firefox 78.7.0esr, 76.0 and 84.0.2 but the issue does not reproduce for us. We also tried reproducing this on MacBook Pro (macOS 10.14) with Firefox 76.0a1 (2020-05-02) as well and no luck there either. We used the initial reported video from comment 0 as well as different random ones with color changing.

Does this issue reproduce consistently? Are there any specific steps that need to be done or any particular YouTube videos that need to be opened in order to reproduce the issue?

If the issue is easily reproducible can you try using mozregression to find a regression range?

Thank you!

Flags: needinfo?(djraymond1)
Flags: needinfo?(cheapgood)
Blocks: gfx-stalled
No longer blocks: gfx-triage

It doesn't happens with mac mini, because only happens with macbook's display, not the externel display. (Apple says retina display)
I think this is happening with <Apple Silicon Device with it's display, NOT ON EXTERNEL DISPLAY> (Mac mini requires externel display, and I couldn't reproduce on that device)
Every youtube video is having this problem at least I watched, and one of it is also comment 0's reported video.

Firefox needs to be like my attachment I've attached before ( https://bug1634920.bmoattachments.org/attachment.cgi?id=9198311 ) : Browser Zoomed mode, not on fullscreen or theater mode
I didn't check if this happens only if dock is hidden. As you see in the achivement, can't see dock because I've turned on Automactually hide dock on the system settings, and this is happening.

BTW, It is not happening for me right now, I don't know why it is fixed. It might be Firefox 85 update / (maybe) youtube's update / or something else.

Flags: needinfo?(djraymond1)

Hi,

I tried to reproduce the issue using a MacBook Air (M1, 2020) macOS Big Sur 11.1 , with Fx 84.0.2, Release 85, Beta 86.0b4, Nightly 86.0a1 (20-01-2021) and latest Nightly 87.0a1 but without success. I tried to reproduce it using the video from the description and other random youtube videos, in normal view, full screen mode and zoomed, with and without hidden dock. In my attempts I only used clean profiles.

Thanks.

cheapgood, can you still reproduce this?

@jrmuizel, nope I haven't had the issue since my last post.

Flags: needinfo?(cheapgood)
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.