Closed Bug 1636006 Opened 1 year ago Closed 1 year ago

Restore py2 compatibility in xpidl.py (SearchFox May 7 indexing failure)

Categories

(Core :: XPCOM, defect)

defect

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox-esr68 --- unaffected
firefox75 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Filing in advance because I had a test run today fail and I'm sure the indexer tomorrow will fail in the same way. This is because xpidl.py got updated in m-c to require python3 or something, and we run with idl-analyze.py using python2.

Traceback (most recent call last):
  File "/home/ubuntu/mozsearch/scripts/idl-analyze.py", line 2, in <module>
    import xpidl
  File "/tmp/pymodules/xpidl.py", line 138
    self.location, warning=True), file=sys.stderr)
                                      ^
SyntaxError: invalid syntax

This is a bit tricky because xpidl.py is going to be py3 in m-c but remain py2 in m-b, m-r, and esr branches. So we'll need to deal with both. One path forward is to make py2 and py3 versions of idl-analyze.py and invoke the appropriate one depending on which version of xpidl.py we're dealing with.

Eventually of course it would be nice to run this on the taskcluster job instead so it stays in sync with whatever upstream is doing, but in the short-term we can do this to get the indexer unbroken (hopefully) without loss of functionality.

Assignee: nobody → kats

After some experimentation with py3 conversion I think the fact that xpidl.py is not py2 compatible might be unintentional and can be easily fixed.

Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4adaffd18688
Restore py2 compatibility in xpidl.py. r=froydnj
Component: Searchfox → XPCOM
Product: Webtools → Core
Summary: May 7 indexing failure → Restore py2 compatibility in xpidl.py (SearchFox May 7 indexing failure)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Set release status flags based on info from the regressing bug 1634864

You need to log in before you can comment on or make changes to this bug.