Closed Bug 1637532 Opened 5 months ago Closed 2 months ago

[css-pseudo-4] Animations on ::marker?

Categories

(Core :: CSS Transitions and Animations, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: mozilla-apprentice, Assigned: birtles)

References

Details

(Keywords: dev-doc-needed)

Attachments

(2 files)

A resolution was made for csswg-drafts/#4814.

[css-pseudo-4] Animations on ::marker?

  • RESOLVED: allow transitions on ::marker and allow animations with animations happening and animation rules applying the style

Discussion.

Component: Layout → CSS Transitions and Animations
See Also: → 1636562

We already support ::marker animations, so closing as WORKSFORME.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → WORKSFORME

Sean, as of 78.0a1 (2020-05-13) this hasn't shipped; where can I track that?

::marker does not support animations with layout.css.marker.restricted=true (the default).

This bug should make ::marker support animations with layout.css.marker.restricted=true, but only the allowed properties should be animated.

With layout.css.marker.restricted=false, ::marker already supports animations with arbitrary properties.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Oh, I thought we had already shipped this. ::marker animations were enabled in 68 beta (admittedly, the last time I checked this).

Mats: With this resolution can we flip the pref? Or is there a fair work to be done to restrict to the allowed properties.

Flags: needinfo?(mats)

I'm pretty sure we shipped ::marker in 68. However, in bug 1552578 we restricted the set properties that could be used with it and shipped that in Firefox 69. (Hence why CSS animations on ::marker worked in 68 but don't now.)

In this bug I think we just need to add animations and transitions properties to the set of allowed properties (i.e. add the various applies_to_marker: true / APPLIES_TO_MARKER annotations).

Unfortunately bug 1552578 didn't apply the property restriction to Web Animations, but we have bug 1636562 for that.

Flags: needinfo?(mats)

The severity field is not set for this bug.
:nordzilla, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(enordin)

Marking this as S3 for now.

Severity: -- → S3
Flags: needinfo?(enordin)

Blink is preparing to ship this: https://groups.google.com/a/chromium.org/g/blink-dev/c/80j6AEWI-_s?pli=1
(And the spec has finally been updated with the resolution to add these properties.)

Assignee: nobody → brian
Status: REOPENED → ASSIGNED

This should probably be blocked by bug 1636562 since otherwise we can effectively set properties on ::marker that shouldn't be allowed by using an animation (see attachment 9163925 [details] for an example).

Depends on: 1636562
See Also: 1636562

(In reply to Brian Birtles (:birtles) from comment #12)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b5e36198e5d942036d5a7ee2cda82d10a0339379

One of the test failures here is because we don't treat text-combine-upright as non-animatable.

Keywords: dev-doc-needed

As per the following change to the spec:

https://github.com/w3c/csswg-drafts/commit/6b3d7240b57aec90846c4b6b753bdc4bf7726c8c

The additional failure annotation is added because we don't currently treat
text-combine-upright as non-animatable and this patch exposes the existing bug
(bug 1654195).

(In reply to Brian Birtles (:birtles) from comment #13)

(In reply to Brian Birtles (:birtles) from comment #12)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b5e36198e5d942036d5a7ee2cda82d10a0339379

One of the test failures here is because we don't treat text-combine-upright as non-animatable.

Filed as bug 1654195.

Pushed by bbirtles.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/870a3fac5d60
Allow animations and transitions on ::marker; r=boris
Status: ASSIGNED → RESOLVED
Closed: 5 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Regressions: 1654639
No longer regressions: 1654639
You need to log in before you can comment on or make changes to this bug.