Closed Bug 1620055 (desktop-zoom-nightly) Opened 9 months ago Closed 4 months ago

[meta] Enable desktop zooming on the nightly channel

Categories

(Core :: Panning and Zooming, task, P3)

task

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox75 --- wontfix
firefox81 --- fixed

People

(Reporter: botond, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, meta)

Attachments

(1 file)

This meta bug tracks issues blocking the enablement on desktop zooming by default on the nightly channel.

See Also: → desktop-zoom-xp
Priority: -- → P3
Depends on: 1621740
Depends on: 1622020
Depends on: 1622040
Depends on: 1632443
Depends on: 1632268
Depends on: 1634490
Depends on: 1557160
Depends on: 1636273
Depends on: 1636277
Depends on: 1637003
Depends on: 1636911
Depends on: 1637776
No longer depends on: 1622040
Depends on: 1639448
Depends on: 1639450
No longer depends on: 1639764
Depends on: 1641300
Depends on: 1641996
See Also: → 1642340
Depends on: 1642340
No longer depends on: 1642340
Depends on: 1642500
Depends on: 1643223
Depends on: 1643517

This should probably be documented at https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features once implemented.

Sebastian

Keywords: dev-doc-needed

It's already implemented, so we should document it now I think.

No longer depends on: 1637003
No longer depends on: 1641300

(In reply to Timothy Nikkel (:tnikkel) from comment #2)

It's already implemented, so we should document it now I think.

Then I guess, I misunderstand the feature. What always worked for me is zooming in and out pinching two fingers on the touchpad of my Windows 10 laptop. Switching apz.allow_zooming to true doesn't change that behavior for me.
So could you please shortly explain what the desktop zooming does differently and how it works? That would help a lot to properly describe it on MDN.

Sebastian

Flags: needinfo?(ktaeleman)
Flags: needinfo?(ktaeleman) → needinfo?(tnikkel)

Currently pinching on a desktop or laptop on a touchpad or touchscreen with do a "reflow zoom" where it zooms in discrete steps and things jump around. This is different from "apz" or "pinch" zoom which currently happens on mobile if you do the pinch gestures on the screen and it is a smooth operation where everything gets bigger without reflowing.

Desktop zooming is to bring this smooth type of zoom to desktop.

If you enable apz.allow_zooming on Windows you will be able to do this smooth pinch zooming if you do the pinch gestures on the touchscreen (if it exists) of your laptop. If you have a laptop with a precision touchpad then you can further enable the pref apz.windows.use_direct_manipulation and that should allow you to do the pinch gesture on your touchpad and have it do the smooth pinch zooming.

Does that all make sense?

Flags: needinfo?(tnikkel)

Thank you very much for the clarification, Timothy! Unfortunately, my laptop neither has a touch screen nor a precision touchpad (but Dell Touchpad driver), so I can't test it myself right now.

I have added it under https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#desktop-zooming now (taking Firefox 42 as the earliest version, as that was the version that introduced the preference according to bug 1186004).

Sebastian

I don't see it on that page now.

Depends on: 1644529

I wasn't seeing it either so I made a no-op change to the page to rebuild it and it shows up now.

Depends on: 1644952
Depends on: 1645433
Depends on: 1647034
No longer depends on: 1645433
Depends on: 1647546
Depends on: 1648489
No longer depends on: 1648425
Depends on: 1651511
Depends on: 1653576
Depends on: 1653700
Depends on: 1653924
Depends on: 1653927
No longer depends on: 1647546
Depends on: 1642340
Depends on: 1654290
No longer depends on: 1654290
No longer depends on: 1637776
Assignee: nobody → kats
Status: NEW → ASSIGNED

Is it okay to land this with Bug 1654933 unfixed?

(In reply to Kagami :saschanaz from comment #9)

Is it okay to land this with Bug 1654933 unfixed?

Are you still seeing bug 1654933? That bug should be "fixed" by bug 1655160 (ie flipping a pref so the code that regressed it is no longer active). I'm leaving the bug open to track a proper fix.

Ah cool, I'm indeed not seeing the issue anymore. Thanks!

Depends on: 1656689
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ed6ec0c8220
Turn on allow_zooming on nightly desktop builds. r=ktaeleman

Dang, the ownership of DManipEventHandler shouldn't be too complicated. Hopefully not hard to figure out.

From the log:

WARNING: mDmManager->Deactivate() failed: file /builds/worker/checkouts/gecko/widget/windows/DirectManipulationOwner.cpp, line 659

That is why it's leaking. Not sure why it's failing though.

Depends on: 1657073

Moved the dmanip leak to bug 1657073 with fix.

Thanks! I looked at the autoland push and there as another failure as well, which I've filed bug 1657102 for.

Flags: needinfo?(kats)
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a09e4ce9ebba
Turn on allow_zooming on nightly desktop builds. r=ktaeleman
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
No longer depends on: 1656689
No longer depends on: 1642500
No longer depends on: 1639450
No longer depends on: 1636277
No longer depends on: 1653576
Regressions: 1658001
Regressions: 1658487

Incidentally, metrics showing that now there's a lot of zooming activity on Nightly: https://mzl.la/3iB9rCz

Regressions: 1658647
Regressions: 1661108
Regressions: 1664101
See Also: → 1664558
See Also: 1664558
Regressions: 1663731

Looks like we have covered this appropriately on https://wiki.developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#UI

So I think the docs for this are completed for now.

You need to log in before you can comment on or make changes to this bug.