Closed Bug 1640913 Opened 2 years ago Closed 2 years ago

[mac] Clear All History warning message is unreadable in the preferences while dark mode is set on macOS

Categories

(Firefox :: Preferences, defect)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
Firefox 78
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- wontfix
firefox78 --- verified

People

(Reporter: csasca, Assigned: ntim)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • Firefox 77.0
  • Firefox 78.0a1

Affected platforms

  • macOS 10.15

Steps to reproduce

  1. Launch Firefox
  2. Access about:preferences#privacy
  3. Scroll down to History and select "Clear History"
  4. From the "Time range to clear", open the dropdown and select "Everything"

Expected result

  • The warning message is visible

Actual result

  • The warning message has a white background and the message is not visible

Regression range

  • Will see for a regression

Additional notes

  • Have Dark theme active in the macOS system settings.
  • The issue can be seen in this attachment
Has Regression Range: --- → no
Has STR: --- → yes

This feels like it should be looked at by the frontend team first. Setting severity back to -- so it doesn't get missed in triage.

Severity: S3 → --
Component: Layout → Preferences
Product: Core → Firefox

This was supposed to be fixed by bug 1546582. The CSS from inside sanitizeDialog.css that sets a background to Window but no foreground colour, overrides the CSS in preferences.css that sets the background to be some variable.

Depends on: 1546582
Has Regression Range: no → yes

This is all a big mess. The root cause is reusing this dialog inside as well as outside the prefs, but always including preferences.css (since bug 1379338). It's not clear to me why we'd need it there. There are no preference elements in there, and none of the variables are available because the common in-content sheet is not included, so little of it even works.

Before bug 1631289, in the preferences, we included that sheet a second time which meant it overrode the identical selectors from sanitizeDialog.css . Now we no longer do that, this is broken.

I think the correct solution is likely to remove preferences.css from the browser/base/content/sanitize.xhtml markup. That leads to some shifts in the dialog's layout (when not opened in the preferences) on my mac, but if anything it looks more native to me. With rc already built, I don't think we can fix it this way in 77 though.

Dão, does that sound like the right thing or am I missing something here?

Severity: -- → S2
Flags: needinfo?(dao+bmo)
Summary: [mac] Clear All History warning message is not visible while dark mode is set on macOS → [mac] Clear All History warning message is unreadable in the preferences while dark mode is set on macOS

I provided a patch that should fix the issue. My fxtree extension have been broken for a bit of time now and I haven't built in the last month, so I haven't tested this yet. Feel free to finish off the patch :)

(I don't have a preference regarding including preferences.css or not though)

Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED
Attachment #9152503 - Attachment description: Bug 1640913 - Clean up sanitizeDialog.css. → Bug 1640913 - reduce duplication in the sanitizeDialog.css files and fix the warning background in macOS dark mode in the preferences
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5690a9ce19cc
reduce duplication in the sanitizeDialog.css files and fix the warning background in macOS dark mode in the preferences r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 78
Flags: needinfo?(dao+bmo)
Flags: qe-verify+

Confirmed the issue at the initial report.
Fix verified with 78.0b8 on macOS 10.15.5.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
See Also: → 1652890
You need to log in before you can comment on or make changes to this bug.