Closed Bug 1641532 Opened 1 year ago Closed 1 year ago

2.9 - 17.82% raptor-tp6- (linux64, macosx1014-64-shippable, windows10) regression on push 2bccc3e80006f2ad27060453135b19fac2d43460 (Tue May 26 2020)

Categories

(Core :: DOM: Networking, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox76 --- unaffected
firefox77 --- unaffected
firefox78 --- disabled
firefox79 --- fixed

People

(Reporter: Bebe, Assigned: mayhemer)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, perf-alert, regression, Whiteboard: [necko-triaged])

Perfherder has detected a raptor performance regression from push 2bccc3e80006f2ad27060453135b19fac2d43460. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

18% raptor-tp6-yahoo-mail-firefox-cold not-replayed macosx1014-64-shippable opt 288.58 -> 340.00
18% raptor-tp6-yahoo-mail-firefox-cold not-replayed windows10-64-shippable-qr opt 303.58 -> 357.25
17% raptor-tp6-yahoo-mail-firefox-cold not-replayed windows10-64-shippable-qr opt 307.00 -> 359.75
17% raptor-tp6-yahoo-mail-firefox-cold not-replayed linux64-shippable opt 300.17 -> 350.08
16% raptor-tp6-yahoo-mail-firefox-cold not-replayed linux64-shippable-qr opt 303.00 -> 350.42
15% raptor-tp6-facebook-redesign-firefox-cold not-replayed windows10-64-shippable opt 276.96 -> 318.50
15% raptor-tp6-yahoo-mail-firefox-cold not-replayed windows10-64-shippable opt 302.08 -> 347.25
12% raptor-tp6-google-mail-firefox-cold replayed linux64-shippable-qr opt 1,548.04 -> 1,362.75
10% raptor-tp6-facebook-redesign-firefox-cold not-replayed windows7-32-shippable opt 292.21 -> 321.00
8% raptor-tp6-facebook-redesign-firefox-cold not-replayed linux64-shippable-qr opt 329.08 -> 356.33
8% raptor-tp6-facebook-redesign-firefox-cold not-replayed linux64-shippable opt 323.25 -> 348.00
7% raptor-tp6-twitter-firefox-cold windows10-64-shippable opt 633.23 -> 678.11
6% raptor-tp6-facebook-redesign-firefox-cold windows10-64-shippable opt 919.06 -> 977.79
4% raptor-tp6-yahoo-mail-firefox-cold confidence windows10-64-shippable-qr opt 76.67 -> 73.58
4% raptor-tp6-facebook-redesign-firefox-cold fcp windows7-32-shippable opt 1,037.83 -> 1,076.58
4% raptor-tp6-yahoo-mail-firefox-cold confidence macosx1014-64-shippable opt 76.92 -> 74.08
4% raptor-tp6-yahoo-mail-firefox-cold confidence linux64-shippable opt 75.17 -> 72.42
4% raptor-tp6-twitter-firefox-cold linux64-shippable-qr opt 731.75 -> 758.24
3% raptor-tp6-facebook-redesign-firefox-cold fcp windows10-64-shippable opt 1,041.96 -> 1,074.67
3% raptor-tp6-yahoo-mail-firefox-cold confidence linux64-shippable-qr opt 75.96 -> 73.67
3% raptor-tp6-reddit-firefox-cold loadtime linux64-shippable-qr opt 2,791.17 -> 2,873.42
3% raptor-tp6-reddit-firefox-cold loadtime linux64-shippable opt 2,732.79 -> 2,811.92

Improvements:

28% raptor-tp6-microsoft-firefox-cold not-replayed linux64-shippable opt 238.00 -> 172.17
23% raptor-tp6-microsoft-firefox-cold loadtime linux64-shippable opt 893.42 -> 687.58
18% raptor-tp6-instagram-firefox-cold loadtime linux64-shippable-qr opt 1,406.00 -> 1,156.67
17% raptor-tp6-google-mail-firefox-cold not-replayed linux64-shippable-qr opt 383.62 -> 317.42
16% raptor-tp6-microsoft-firefox-cold loadtime linux64-shippable-qr opt 843.17 -> 705.67
11% raptor-tp6-microsoft-firefox-cold loadtime windows7-32-shippable opt 675.54 -> 599.08
7% raptor-tp6-microsoft-firefox-cold confidence linux64-shippable opt 75.33 -> 80.67
6% raptor-tp6-instagram-firefox-cold replayed windows10-64-shippable-qr opt 1,170.12 -> 1,243.50
6% raptor-tp6-instagram-firefox-cold replayed windows10-64-shippable opt 1,175.75 -> 1,244.17
5% raptor-tp6-instagram-firefox-cold replayed windows7-32-shippable opt 1,179.75 -> 1,234.17
4% raptor-tp6-instagram-firefox-cold replayed linux64-shippable opt 1,231.58 -> 1,278.42
2% raptor-tp6-google-mail-firefox-cold loadtime windows10-64-shippable-qr opt 634.25 -> 621.25

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Component: Performance → DOM: Networking
Flags: needinfo?(honzab.moz)
Product: Testing → Core

Set release status flags based on info from the regressing bug 1639607

Depends on: 1637671
Depends on: 1642140

I'm currently investigating mainly the most impacted raptor-tp6-yahoo-mail-firefox-cold not-replayed on win 10, opt build, locally. The page preloads an icon, with too high priority during the render-blocked phase (bug 1642140) and does it twice because of referrer policy change being made between the prescan and dom building phase (bug 1637671).

I have a patch for bug 1642140 that needs a confirmation.

I don't have a patch for bug 1637671, but I have a workaround in bug 1642325.

Flags: needinfo?(honzab.moz)
Depends on: 1642325

I assume non of the patches helps? This compare is the current (1 day old) mozilla-central with preload enabled by default and the two patches on top of it. I assume there should be -18% improvement, right?

Flags: needinfo?(fstrugariu)

OK, this compare looks a bit better. Let's see how the regression moves after the two bugs get landed.

You are correct we should have around the same amount of improvements as the regressions above.
As the Bug 1642325 - Exclude referrer policy from the preload hash key to workaround bug 1637671 had

Improvements:

18% raptor-tp6-facebook-redesign-firefox-cold fcp linux64-shippable opt 1,026.00 -> 844.17
17% raptor-tp6-facebook-redesign-firefox-cold fcp windows10-64-shippable-qr opt 956.00 -> 790.25
17% raptor-tp6-facebook-redesign-firefox-cold windows7-32-shippable opt 971.75 -> 805.53
17% raptor-tp6-facebook-redesign-firefox-cold windows10-64-shippable-qr opt 920.06 -> 763.73
17% raptor-tp6-facebook-redesign-firefox-cold windows10-64-shippable opt 986.99 -> 820.19
16% raptor-tp6-facebook-redesign-firefox-cold fcp linux64-shippable-qr opt 1,078.25 -> 902.42
16% raptor-tp6-facebook-redesign-firefox-cold fcp windows10-64-shippable opt 1,066.75 -> 896.08
16% raptor-tp6-facebook-redesign-firefox-cold fcp windows7-32-shippable opt 1,069.42 -> 898.75
14% raptor-tp6-facebook-redesign-firefox-cold windows10-64-shippable-qr opt 894.87 -> 766.01
13% raptor-tp6-facebook-redesign-firefox-cold fcp macosx1014-64-shippable opt 1,506.25 -> 1,304.42
13% raptor-tp6-facebook-redesign-firefox-cold linux64-shippable opt 921.44 -> 798.83
13% raptor-tp6-facebook-redesign-firefox-cold linux64-shippable-qr opt 953.73 -> 830.24
10% raptor-tp6-facebook-redesign-firefox-cold macosx1014-64-shippable opt 1,378.67 -> 1,234.60
8% raptor-tp6-yahoo-mail-firefox-cold not-replayed linux64-shippable opt 350.08 -> 323.17
7% raptor-tp6-yahoo-mail-firefox-cold not-replayed linux64-shippable-qr opt 351.50 -> 325.67
7% raptor-tp6-yahoo-mail-firefox-cold not-replayed macosx1014-64-shippable opt 342.08 -> 318.92
3% raptor-tp6-yahoo-mail-firefox-cold confidence linux64-shippable opt 72.58 -> 74.75

I would consider this fixed

Flags: needinfo?(fstrugariu)

\o/

I'll leave this at your discretion to close this bug. Thanks.

Severity: -- → S3
Priority: -- → P1
Whiteboard: [necko-triaged[
Whiteboard: [necko-triaged[ → [necko-triaged]
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Assignee: nobody → honzab.moz
Target Milestone: --- → mozilla79
No longer depends on: 1637671
You need to log in before you can comment on or make changes to this bug.