Closed Bug 1639607 Opened 11 months ago Closed 11 months ago

Enable <link rel=preload> on Nightly and Early Beta only by default

Categories

(Core :: DOM: Networking, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
relnote-firefox --- -
firefox78 --- fixed

People

(Reporter: mayhemer, Assigned: mayhemer)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete, Whiteboard: [necko-triaged])

Attachments

(1 file)

This will only flip the platform pref network.preload, no other changes will be made.

Priority: -- → P1
Severity: -- → S2
Whiteboard: [necko-triaged]
Depends on: 1637039
Pushed by honzab.moz@firemni.cz:
https://hg.mozilla.org/integration/autoland/rev/2bccc3e80006
Enable <link rel=preload> on Nightly and Early Beta only by default, r=dragana,NhiNguyen
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Release Note Request (optional, but appreciated)
[Why is this notable]: Enables a major web feature for preloading resources
[Affects Firefox for Android]: Fenix
[Suggested wording]: Support for the web performance related feature <link rel="preload"> and Link: rel=preload response header for preloading page subresource in andvance and with higher priority
[Links (documentation, blog post, etc)]: https://developer.mozilla.org/en-US/docs/Web/HTML/Preloading_content

relnote-firefox: --- → ?
Keywords: dev-doc-needed
Keywords: dev-doc-needed
Regressions: 1642303
Regressions: 1643077

I've added a note to our experimental features page, clarifying the support status of this:

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Experimental_features#HTML

We don't normally release note things that aren't riding to release.

FWIW, looks like this pref is making some good improvements, bug 1647646 has more info.

Regressions: 1647646

When will this be enabled by default in release?

(In reply to Ben McCann from comment #10)

When will this be enabled by default in release?

Looks like it's enabled by default in release as of bug 1626997 (which landed in version 86, currently beta and hitting release next week I believe).

You need to log in before you can comment on or make changes to this bug.