Closed Bug 1642183 Opened 6 months ago Closed 6 months ago

Pinned top sites should not be shown in "Top Sites" address bar feed if NTP or Top Sites on NTP are not enabled

Categories

(Firefox :: Address Bar, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1628025
Tracking Status
firefox78 --- wontfix

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: nightly-community)

Previously commented about this in bug 1627858 comment 64:

I think that ignores a larger problem, though - if the user is not using the Top Sites feature in about:home, why would they care about pins at all?

If bug 1623666 needs to happen, I think it needs to take into consideration whether Top Sites or about:home is enabled - and if not, pins and reordering of items on about:home is meaningless and it just needs to be based solely on historical data.

Since then, bug 1642177 was filed, where the user clearly has a pinned top site in their top sites feed, but is showing a site that has not been accessed in years.

Steps to reproduce:

  1. Ensure Top Sites is enabled in about:preferences#privacy Address Bar
  2. Ensure that there is at least one pinned tab in the top row of NTP
  3. Either
    3a. Disable Top Sites in about:preferences#home
    OR
    3b. Disable Firefox Home for homepage/new windows or new tabs
  4. Click in address bar

What happens:

I see a pinned top site in the address bar.

Expected result:

Since I am not using either NTP or the Top Sites feature in NTP, a list of customized top sites is meaningless to me, so I should see top sites solely based on frecency/history data, not based on customization in NTP Top Sites.

Blocks: 1627858
See Also: → 1642177
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1628025
You need to log in before you can comment on or make changes to this bug.