Closed Bug 1642211 Opened 1 year ago Closed 2 months ago

Ability to sort logins by username

Categories

(Firefox :: about:logins, enhancement, P3)

76 Branch
enhancement

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox-esr68 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- wontfix
firefox93 --- verified

People

(Reporter: baldurien, Assigned: pyjacpp)

References

(Regression)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

I use Fx Sync to synchronize tab (I mainly send links) between work, my mobile device and personal computer: with recent version of Firefox, Sync was "completed" with the password sync.

Firefox Sync was set to synchronize my password.
It is not that I use them that much now, since I use keepass, but still I have some password than I did not add for various personal reason.

As I wanted to delete the synchronized password, I was faced with one modern plague: to "simplify" UI, we no longer have component/functionnality such as:

  • A table with columns (like old Password Manager !)
  • A multi selection on the list or table
  • Ability to DELETE entries in MASS.
  • Ability to SORT entries by name rather than by SITE

Actual results:

Firefox Sync synchronized my password: I wanted to delete but NOT ONE BY ONE with a "Are you sure" popup each time.

Expected results:

The UI should have been the same as password manager, or at least retain functionality such as :

  • Sorting by name
  • Deleting multiple entries at once rather than one at a time.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Password Manager
Product: Firefox → Toolkit

I agree with you but unfortunately that wasn't what was designed :-(

(In reply to baldurien from comment #0)

  • A multi selection on the list or table
  • Ability to DELETE entries in MASS.

These two are bug 1208194 and has someone who will be working on it very soon.

  • Ability to SORT entries by name rather than by SITE

I guess you mean by username, not site name? If so, we can change this bug to focus on that since I don't see it filed yet. What is the use case for this?

Status: UNCONFIRMED → NEW
Component: Password Manager → about:logins
Ever confirmed: true
Product: Toolkit → Firefox
Summary: Mass delete entries in Firefox Lockwise → Ability to sort logins by username
Flags: needinfo?(baldurien)

Yes, I meant by username.

And yes, https://bugzilla.mozilla.org/show_bug.cgi?id=1208194 works for me.
I sure hope it would have been implemented before I found those naughty password entry that should not have been there :o

Flags: needinfo?(baldurien)

Hi, thanks. Could you help answer: "What is the use case for this?". It can help to figure out how to address the problem.

Severity: -- → N/A

The use case is simple : I have several time the same login because I use provisioned VM with the same account.
Since I had my other password imported into my account, having this feature would allow me to sort by account, then remove the bad entries.

Also, and probably the most important, it was a table with columns before Firefox Lockwise: said column allowed to sort, and probably filter, by the column because that was built in the component.

While sorting is not the same as fixing the UX/UI, please do consider that those kind of change (switching from a table component to a list) may be worse than what was there at the beginning: Microsoft have a clear example of what NOT to do with table and list: simply open Program View, and you will have program displayed on... approx 20% on the screen, with ellipsis because text does not fit, even on a 1080p with 27". Hopefully, they did not yet remove the old Program view, which use a table, which span the width of the screen.

That's probably the point here: you replace Password Manager, which used tables, by a FIrefox Lockwise, which use list, which may have a better look (and it does, to my opinion), but you remove feature inherent to the component you were using: those feature were almost free, as sorting is pretty much standard on such component.

OK, thanks. In case you didn't know, you can filter the logins using the search box at the top of the page and that will search within the website address, username, and passwords fields (the latter only if you don't have Master Password enabled). If you have that combined with bug 1208194 things should be much easier for you.

Has Regression Range: --- → yes
Has STR: --- → irrelevant
Priority: -- → P3
Regressed by: about-logins

Add the ability to sort logins by username.

Assignee: nobody → pyjacpp
Status: NEW → ASSIGNED

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:pyjacpp, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(pyjacpp)
Flags: needinfo?(jaws)

Requested landing so removing NIs.

Flags: needinfo?(pyjacpp)
Flags: needinfo?(jaws)
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e1652be63434
Ability to sort logins by username. r=jaws,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

I have verified this issue using the latest Nightly 93.0a1 (Build ID: 20210809213353) on Windows 10 x64, Ubuntu 20.04 and macOS 11.5.1.

  • The “Username(A-Z)” and “Username(Z-A)” options are displayed in the “Sort by” dropdown and all saved logins are correctly sorted when these options are selected.
Status: RESOLVED → VERIFIED

Simon, I just tried it out. I see the options by the sorting does not happen. Would that need to be filed as a new ticket?

Hi, Albert! Yes, I’ve already logged this issue (Bug 1725915) which I also encountered while verifying the last fix that was landed (Bug 1592682) and seems to have caused this regression. Thank you!

You need to log in before you can comment on or make changes to this bug.