Closed Bug 1642330 Opened 4 months ago Closed 3 months ago

Non-active Profiler toolbar icon and text are mirrored incorrectly when placed in overflow menu

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

78 Branch
defect

Tracking

(firefox-esr68 unaffected, firefox77 unaffected, firefox78 verified, firefox79 verified)

VERIFIED FIXED
Firefox 79
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- verified
firefox79 --- verified

People

(Reporter: Fanolian+BMO, Assigned: gregtatum)

References

(Regression)

Details

(Keywords: nightly-community, regression, reproducible)

Attachments

(2 files)

Attached image Profiler icon.png

Thank you for helping make Firefox better. If you are reporting a defect, please complete the following:

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0
Build ID: 20200601093812

What were you doing?

Please tell us what site you were on, and what steps led to the error you are reporting

  1. Hamburger menu > Customize….
  2. Drag and drop Profiler icon into Overflow Menu.

What happened?

What, if any, error messages did you see? Did the browser crash? Screenshots or screen recordings can be attached to this report and are helpful in isolating and replicating the bug.

Please refer to attached screenshot.

When profiler is not recording:
Icon location is flipped to the right side. Icon itself is mirrored as expected.
text is mirrored and placed next to the wrongly placed icon.

The icon and text return to their expected location when a profile is being recorded.

What should have happened?

Was was the expected result? ("Not crashing" may be a valid answer.)

Icon is placed at the left, aligning with other icons.
Text is not mirrored.

Anything else we should know?

Do you have extensions installed? You can also go to about:support in another window or tab and attach the report it generates to this bug.

My system and Nightly are en-US (LTR). I didn't test on a RTL locale.

Thanks for the report! My patch in bug 1621015 will fix this.

Assignee: nobody → gtatum

I'm submitting this as a separate patch as I plan on requesting for uplift.

Flags: needinfo?(gtatum)
Duplicate of this bug: 1643315
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Duplicate of this bug: 1644121
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/463cb8d56f90
Fix profiler icon in the overflow menu; r=julienw
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

Were you still planning to nominate this for uplift? We have one beta left this cycle before 78 goes to RC.

Flags: needinfo?(gtatum)

Comment on attachment 9153958 [details]
Bug 1642330 - Fix profiler icon in the overflow menu; r?julienw

Beta/Release Uplift Approval Request

  • User impact if declined: The profiler menu button, a fairly low usage feature would show up backwards in the overflow menu.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This feature has fairly low usage, and is mostly used internally. The tool is still usable, just flipped the wrong way.
  • String changes made/needed:
Flags: needinfo?(gtatum)
Attachment #9153958 - Flags: approval-mozilla-beta?
Duplicate of this bug: 1646526

Comment on attachment 9153958 [details]
Bug 1642330 - Fix profiler icon in the overflow menu; r?julienw

approved for 78.0b9

Attachment #9153958 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduce the issue on Firefox 78.0a1 (2020-05-28) (20200528032513) on Windows 10 and Ubuntu 18.04.4 .
Verified fixed on Firefox 79.0a1 (2020-06-18) (20200618212828).

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Verified fixed on Firefox beta dev edition 78.0b9 (20200619002543) on Windows 10 and Ubuntu 18.04.4
In Beta 78, the Profiler option is not displayed under Customize options. Should this be verified on Beta78? Is there any config parameter that should be updated so that the option be available also on Beta 78?

Flags: needinfo?(gtatum)

To turn it on in Beta:

Flags: needinfo?(gtatum)

Verified fixed on Firefox beta 78.0 (20200625152958) on Windows 10 and Ubuntu 18.04.4.

You need to log in before you can comment on or make changes to this bug.