Closed Bug 1642462 Opened 5 months ago Closed 4 months ago

Move more app prefs to brand.properties

Categories

(SeaMonkey :: Build Config, task)

Tracking

(seamonkey2.53? affected, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.77
Tracking Status
seamonkey2.53 ? affected
seamonkey2.57esr ? affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.4)

Attachments

(1 file, 2 obsolete files)

There are a number of app.* prefs that would be better in brand.properties
app.support.baseURL
app.update.url.details
app.update.url.manual

At the same time let's switch from http to https for the URLs and remove the now unused communicator-region and region.properties from common/

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.4
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: 1 moved string, 2 new strings

Attachment #9153233 - Flags: review?(frgrahl)
Attachment #9153233 - Flags: approval-comm-release?
Attachment #9153233 - Flags: approval-comm-esr60?
Comment on attachment 9153233 [details] [diff] [review]
Move some app prefs to brand.properties

LGTM
Attachment #9153233 - Flags: review?(frgrahl)
Attachment #9153233 - Flags: review+
Attachment #9153233 - Flags: approval-comm-release?
Attachment #9153233 - Flags: approval-comm-release+
Attachment #9153233 - Flags: approval-comm-esr60?
Attachment #9153233 - Flags: approval-comm-esr60+

[Triage Comment]
Unbitrotted version

Attachment #9153233 - Attachment is obsolete: true
Attachment #9160205 - Flags: review+
Attachment #9160205 - Flags: approval-comm-release+
Attachment #9160205 - Flags: approval-comm-esr60+

With missing bits put back in.

Attachment #9160205 - Attachment is obsolete: true
Attachment #9160227 - Flags: review+
Attachment #9160227 - Flags: approval-comm-release+
Attachment #9160227 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/a7bca43b95fb
Move more app prefs to brand.properties. r=frg

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.77
You need to log in before you can comment on or make changes to this bug.