Closed Bug 1642806 Opened 3 years ago Closed 3 years ago

Incorrect overlay size after stop/start the camera while the overlay is minimized

Categories

(Firefox :: Site Permissions, defect, P2)

All
Windows
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox79 --- wontfix

People

(Reporter: mconley, Unassigned)

References

(Blocks 2 open bugs, )

Details

Attachments

(3 files)

Affected versions:

Beta 77.0b8
Nightly 78.0a1(2020-05-22)

Affected platforms:

Windows 7
Windows 10

Preconditions:

Flip privacy.webrtc.allowSilencingNotifications to true
Flip privacy.webrtc.legacyGlobalIndicator to false

Steps:

  1. Launch firefox and access: https://meet.google.com/
  2. Start a video call and share the screen.
  3. Minimize the overlay
  4. Stop the camera from the web-app's camera button.

Actual result:

The overlay is restored having a bigger size (see the overlay bottom part).

Expected result:

The overlay should be restored with the same size.

Regression range:

It is a feature implementation regression.

Note: The issue is also reproducible on Zoom.

Attached image Expected size
Attached image Wrong overlay size

The issue still occurs with the newly implemented design and it looks like this.

Hey dbodea, I think this may have been fixed by bug 1650243. Can you confirm?

Flags: needinfo?(daniel.bodea)

The changes made in that bug do NOT fix the issue of this bug, but it works around it because the overlay DOES NOT come back into focus if permissions change.

Flags: needinfo?(daniel.bodea) → needinfo?(mconley)

Okay - in that case, I think this is now INVALID, since the original problem can no longer be reproduced.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mconley)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.