Force domain autocompletion with Ctrl+Enter like in IE

RESOLVED DUPLICATE of bug 37867

Status

SeaMonkey
Location Bar
--
enhancement
RESOLVED DUPLICATE of bug 37867
16 years ago
10 years ago

People

(Reporter: //, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Requested feature
-----------------
It would be nice if Mozilla can have the same Ctrl+Enter feature in the
URL Bar as in the URL Bar of IE.
If you type "yahoo" in the URL Bar and press Ctrl+Enter, the current
URL should change to "www.yahoo.com" and the first DNS lookup should
be "www.yahoo.com"

Current Implementation 
----------------------
The current implementation of Ctrl+Enter in the URL Bar is that Mozilla
opens a new window.

If you type "yahoo" and press Ctrl+Enter or just ENTER, Mozilla will always
do a DNS lookup first to "yahoo" and then to "www.yahoo.com".

The Ctrl+Enter does not trigger the autocompletion. Mozilla always trigger 
the URL autocompletion when he could not find the hostname, like for example
"yahoo" in the current window or in a new one created by Ctrl+Enter.

I found this code where this current behaivior take place:
http://lxr.mozilla.org/mozilla1.0/source/docshell/base/nsWebShell.cpp#722

Notes
-----
If you like the IE Ctrl+Enter feature, vote for this bug.
The discusion started here Bug #37867
(Reporter)

Updated

16 years ago
Severity: normal → enhancement

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 37867 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Please reopen this bug.
This bug is diferent from bug #37867 because in #37867:
1. they ask for many address autocompletion, .com, .org, .net, etc
2. they do a DNS lookup of the string that the user has typed

Here, we want:
1. do only .com autocompletion
2. do not DNS lookup what the user has typed
(Reporter)

Updated

16 years ago
Summary: Force URL autocompletion with Ctrl+Enter like in IE → Force domain autocompletion with Ctrl+Enter like in IE
(Reporter)

Comment 3

16 years ago
Another advantage of not DNS lookup what the user has typed, is speed.
Some users with dial-up have a 2 seconds timeout when Mozilla trys
to load "yahoo".
But, "www.yahoo.com" loads in less than 2 seconds in Mozilla. 
Maybe because of a proxy cache or Mozilla cache, but it load faster.
Oliver, read the summary of that bug. This one is identical to that one.

Comment 5

16 years ago
Domain completion by keyboard shortcut *without* doing a dns lookup on what the
user typed is exactly what bug 37867 is about.
(Reporter)

Comment 6

16 years ago
comment #4
comment #5
I will accept that this bug is a reduced version of #37867 if you want,
but #37867 is not like IE. I want IE like.

Here I state some mayor difference, like:
1. not using .net, .org, .mil, etc
2. don't even configure .net, .org, .country, etc
3. I want Ctrl+Enter to only auto-complete, not new window
4. do not resolve what the user typed. Quote #37867:
   "Another aproch would be that if the user enters a oneword url (such 
   as "altavista") mozilla DNS resolvs
   1. altavista
   2. www.altavista.com
   3. www.altavista.org
   4. www.altavista.net
   5. www.altavista.se
   6. www.altavista.no
   "

You can close this bug, but is not duplicate. 
It is releated and it IS diferent.

I wanted to make Mozilla more user friendly for my friends that
only know IE.
If Mozilla.org does not want IE like URL Bar. Fine by me. I will
always use Mozilla, I have done it since Netscape 1.0.

See you in #37867, thanks.
(Reporter)

Comment 7

16 years ago
As a result of this discussions, the bug #164323 has been filled to request
that Ctrl+Enter for new window open be deprecated.
When Ctrl+Enter is freed, then we can go back to this bug or bug #37867
for the asking the IE feature in the URL Bar.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.