Open Bug 1646135 Opened 7 months ago Updated 2 months ago

Firefox-Wayland doesn't start on the proprietary nvidia driver

Categories

(Core :: Widget: Gtk, defect, P3)

77 Branch
defect

Tracking

()

UNCONFIRMED

People

(Reporter: haaaain, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4173.0 Safari/537.36

Steps to reproduce:

I got kde on wayland running with EGLStreams & the proprietary nvidia driver and tried to open firefox

Actual results:

All i get is a black screen. On gnome it doesnt even start.

On gnome terminal I get:
[GFX1-]: Failed to create EGLSurface
[GFX1-]: We don't have EGLSurface to draw into. Called too early?
Gdk-Message: 14:38:16.467: Error 71 (Erro de protocolo) dispatching to Wayland display.

Which Linux distribution and version do you use?

Opensuse Tumbleweed, nvidia 440.82, firefox 77.0.1

Component: Graphics → Widget: Gtk
Blocks: wayland-gl
Priority: -- → P3

I have tried to run Gnome Wayland and Plasma Wayland with proprietary Nvidia on Ubuntu 20.04, but haven't succeeded in 2 hours of trying.

I edited /etc/default/grub and added nvidia-drm.modeset=1 at the end of GRUB_CMDLINE_LINUX DEFAULT.
Then I ran

# grub-mkconfig -o /boot/grub/grub.cfg
# update-grub
# update-initramfs -u

I created a /etc/profile.d/kwin.sh file that contains

export KWIN_DRM_USE_EGL_STREAMS=1

I made sure that /etc/gdm3/custom.conf contains WaylandEnable=true.
I commented out the "gdm-disable-wayland" line for the nvidia driver in /lib/udev/rules.d/*gdm*.
I installed libnvidia-egl-wayland1.
I rebooted after each change.

# cat /sys/module/nvidia_drm/parameters/modeset
even says Y

But gdm3 doesn't show Wayland.
After switching from gdm3 to sddm I saw Wayland options:
Ubuntu Wayland exited back to the login screen.
Plasma Wayland froze right after login with a black screen.

Now, after 2 hours, I rebooted to an older Debian Testing with Nouveau and Gnome Wayland worked out of the box.
Plasma Wayland froze after some taskbar animations, but I haven't updated this system for a longer time. Will try it again after updating. I will also keep trying to enable EGLStreams for a basic test.

After updating, the stability problem of Plasma Wayland is gone. Nightly works with native Wayland backend on Debian Testing with Nouveau. It's good to know that at least the default configuration works without problem. Now I just need to succeed with enabling EGLStreams on the proprietary driver.
If you wouldn't have said "OpenSUSE Tumbleweed" (rolling release distro), then I would have assumed your Plasma version was just outdated (bug 1644312).

You have to check if ubuntu enables EGLStreams on Mutter builds.

I've tested it on Fedora. If I disable webrender and it works but in an ambiguous way. In WebGL 1 Driver Renderer it says "NVIDIA Corporation -- GeForce GT 1030/PCIe/SSE2" and on GPU #1 "llvmpipe (LLVM 10.0.0, 256 bits)". Window Protocol: wayland/drm.

There's no HW acceleration. If I enable webrender or layers.acceleration.force-enabled i get a black screen.

Depends on: 1650583
No longer depends on: 1650583
Duplicate of this bug: 1670492
You need to log in before you can comment on or make changes to this bug.