Closed Bug 16468 Opened 20 years ago Closed 20 years ago

<IFRAME SRC="..."> changes the window title

Categories

(Core :: Layout: Images, Video, and HTML Frames, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 13385

People

(Reporter: mats, Assigned: pollmann)

References

()

Details

(Whiteboard: [TESTCASE])

TO REPEAT:
1. load a page containing an <IFRAME>

ACTUAL: Initially the real <title> of the document "Testcase for bug 16384" is
displayed in the window titlebar. After first IFRAME source is loaded it is
changed to the title of that document.

EXPECTED: <IFRAME> should not change the window title.

VERSION & OS:
Mozilla nightly build 1999-10-13-13-M11 on Windows NT 4.0 SP5

ADDITIONAL INFO:
Here is a testcase containing <IFRAME SRC="x.gif">
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=2167
Here is a testcase containing <IFRAME SRC="x.html">
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=2173
Whiteboard: [TESTCASE]
Assignee: karnaze → pollmann
Reassigning to Eric.
Status: NEW → ASSIGNED
OS: Windows NT → All
Hardware: PC → All
Will probably have to change webshell to fix this.
*** Bug 15425 has been marked as a duplicate of this bug. ***
I'm not a WebShell expert, but this looks like a dup of bug 13385. It is, in
any case, rather closely related. HTH...
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Yes, frameset frames and iframes use the same code - both create a web shell and
that sets the title upon loading the document.  I'm marking this a dup and
adding myself to the CC list of that bug.

*** This bug has been marked as a duplicate of 13385 ***
Status: RESOLVED → VERIFIED
Marking as verified dup of 13385.
Product: Core → Core Graveyard
Component: Layout: HTML Frames → Layout: Images
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.