Closed Bug 1647480 Opened 2 years ago Closed 1 year ago

Update nsIPrinterEnumerator to use the nsIPrinter interface

Categories

(Core :: Printing: Setup, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: nordzilla, Assigned: nordzilla)

References

Details

(Whiteboard: [print2020_v80])

Attachments

(1 file, 1 obsolete file)

With the introduction of the nsIPrinter interface in [Bug 1646829]

We should update nsIPrinterEnumerator's defaultPrinterName and printerNameList attributes to utilize this new interface.

CLOSED TREE

  • Add new interface for nsIPrinter.
  • Add readonly attribute for printer name.
  • Add implementation of interface: nsPrinter.
  • Rename nsIPrinterEnumerator to nsIPrinterList
  • Ensure nsIPrinterList uses nsIPrinter

CLOSED TREE

  • Add new interface for nsIPrinter.
  • Add readonly attribute for printer name.
  • Add implementation of interface: nsPrinter.
  • Rename nsIPrinterEnumerator to nsIPrinterList
  • Ensure nsIPrinterList uses nsIPrinter
Attachment #9159819 - Attachment is obsolete: true
Duplicate of this bug: 1646829
Attachment #9159821 - Attachment description: Bug 1647480 - Refactor Printer Enumeration to Use nsIPrinter -- WIP → Bug 1647480 - Refactor Printer Enumeration to Use nsIPrinter r=jwatt,alaskanemily
Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6087e976924f
Refactor Printer Enumeration to Use nsIPrinter r=jwatt
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Whiteboard: [print2020_v80]
Blocks: 1650886
Whiteboard: [print2020_v80] → [print2020_v81]
Whiteboard: [print2020_v81] → [print2020_v80]
Whiteboard: [print2020_v80] → [print2020_v81]
Whiteboard: [print2020_v81] → [print2020_v80]
You need to log in before you can comment on or make changes to this bug.