Closed Bug 1647546 Opened 2 years ago Closed 1 year ago

direct manipulation pan/pinch events rollup menus that we don't want to rollup

Categories

(Core :: Widget: Win32, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1653576
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- disabled
firefox79 --- disabled

People

(Reporter: tnikkel, Assigned: kats)

References

(Regression)

Details

(Keywords: regression)

Enable apz.windows.use_direct_manipulation, (restart browser), open a menu (hamburger, help menu, etc), do a two finger pan on the touchpad. Menu is closed. Without direct manip the menu stays open. Assuming this is caused by bug 1636061.

We'll need to figure out how to rollup select dropdowns but not other menus on scroll. Or we could just ignore scrolls (of things other than the select dropdown) while select dropdowns are open.

Pref is still turned off by default and I don't plan to change that for 79 at least.

This also affects touchpad pinch gestures and the right click menu.

Summary: direct manipulation scroll events rollup menus that we don't want to rollup → direct manipulation pan/pinch events rollup menus that we don't want to rollup

The severity field is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)
Severity: -- → S4
Flags: needinfo?(jmathies)
Priority: -- → P3

Parking with me, the patch I'm working on for bug 1653576 will probably fix this too.

Assignee: nobody → kats

Patch on bug 1653576 fixes this. The hamburger menu still rolls up if you scroll the content area (i.e. cursor position is outside the hamburger menu) but AFAICT that is the behaviour we get with apz.allow_zooming=false as well, so it should be fine.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1653576

I'm not sure why this bug was marked as a duplicate of Bug 1653576.
I thought this was referring to the hamburger menu and other browsers menu or doorhangers.

Here are the results while pinch zooming on Firefox menus on Windows 10:
Pinch zooms on the hamburger menu or other browsers menu or doorhangers when the focus is on them using touchscreen zooms the page.
Pinch zooms on the hamburger menu or other browsers menu or doorhangers when the focus is on them using touchpad is ignored.

Pinch zooms on the hamburger menu or other browsers menu or doorhangers when the focus isn't on them using touchscreen or touchpad zooms the page and closes the menu (On chrome the zoom is performed on the page and the menu is still open)

Flags: needinfo?(kats)

(In reply to Hani Yacoub from comment #8)

I'm not sure why this bug was marked as a duplicate of Bug 1653576.
I thought this was referring to the hamburger menu and other browsers menu or doorhangers.

It is. The fix from bug 1653576 addressed the original problems in this bug.

Here are the results while pinch zooming on Firefox menus on Windows 10:
Pinch zooms on the hamburger menu or other browsers menu or doorhangers when the focus is on them using touchscreen zooms the page.

I just tried this, and it zooms the page using reflow zoom which seems like something we should fix. I would expect touchscreen pinches on the hamburger menu to have no effect.

Pinch zooms on the hamburger menu or other browsers menu or doorhangers when the focus is on them using touchpad is ignored.

This seems fine.

Pinch zooms on the hamburger menu or other browsers menu or doorhangers when the focus isn't on them using touchscreen or touchpad zooms the page and closes the menu

This seems fine.

(On chrome the zoom is performed on the page and the menu is still open)

When I tried just now, touchpad zoom didn't close the menu, but touchscreen zoom did close the menu. But anyway, this behaviour isn't specced and it's not super important that we do the same thing as Chrome. More important is that we do things that are "reasonable" from a user's point of view. And more importantly, that we avoid doing unexpected things. Of the behaviours you've described, I think touchscreen zoom over the hamburger menu needs fixing but everything else feels reasonable to me.

Flags: needinfo?(kats)
You need to log in before you can comment on or make changes to this bug.