Closed Bug 1648358 Opened 3 years ago Closed 1 year ago

No sharing indicator is displayed when alerts.useSystemBackend is enabled

Categories

(Firefox :: Site Permissions, defect, P3)

79 Branch
Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
99 Branch
Tracking Status
firefox-esr91 --- wontfix
firefox77 --- disabled
firefox78 --- disabled
firefox79 --- disabled
firefox97 --- wontfix
firefox98 --- wontfix
firefox99 --- fixed

People

(Reporter: philipp, Assigned: emilio)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

at least under windows where i could test the issue, the new sharing indicator is not getting displayed when alerts.useSystemBackend is enabled (which is a non-default value), and there is no indication in the address bar that camera/mic/screen-sharing is taking place in firefox either.

Blocks: 1642799
No longer regressed by: 1642799

This seems to be a regression of Bug 1635257.

Setting the suppress notification flag fails here: https://searchfox.org/mozilla-central/rev/a87a1c3b543475276e6d57a7a80cb02f3e42b6ed/browser/modules/webrtcUI.jsm#451
NS_ERROR_NOT_IMPLEMENTED: Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIAlertsDoNotDisturb.suppressForScreenSharing]

Blocks: 1497425
Severity: -- → S4
OS: Windows 10 → Windows
Priority: -- → P3
Regressed by: 1635257
Has Regression Range: --- → yes
See Also: → 1640705
Summary: No sharing indicator is not displayed when alerts.useSystemBackend is enabled → No sharing indicator is displayed when alerts.useSystemBackend is enabled

Nobody is using the weak reference stuff so remove it.

Assignee: nobody → emilio
Status: NEW → ASSIGNED

This happens to be D76407, but I missed it before writing this.

Depends on D139360

Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0bfe789a1934
Modernize a bit ToastNotification. r=saschanaz
https://hg.mozilla.org/integration/autoland/rev/3edd136f27f6
Implement nsIAlertDoNotDisturb for windows native alerts. r=saschanaz
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 99 Branch
You need to log in before you can comment on or make changes to this bug.