Closed Bug 1648686 Opened 7 months ago Closed 6 months ago

(mac) pan/pinch events rollup menus that we don't want to rollup

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox77 --- unaffected
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- fixed

People

(Reporter: tnikkel, Assigned: kats)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Basically the same bug as bug 1647546 except on mac and only affects pinch gestures.

Actually 78 is affected because all it takes is a pinch gesture on the trackpad to trigger this (no need to turn on desktop zooming or anything).

Hi, would you mind setting a severity for this one?

Flags: needinfo?(botond)

Setting S3 as pinch gestures are not likely to be very common without desktop zooming enabled.

Severity: -- → S3
Flags: needinfo?(botond)
Priority: -- → P3

I can take this one too.

Assignee: nobody → kats

It seems like ShouldRollupOnMouseWheelEvent really means something more like
"ShouldRollupIfPageIsGonnaMove" so it seems appropriate to use in this
situation. Might be worth renaming the function at some point if my interpration
is correct, but the name propagates into xhtml attributes and such so it's
more than I want to do right now.

Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9ef828c9bd89
Don't rollup the hamburger menu when pinching over content (on mac). r=tnikkel
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.