Closed Bug 1649538 Opened 8 months ago Closed 7 months ago

New ASR Snippet Template: One-Scene S2D

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 80
Iteration:
80.2 - July 13 - July 26
Tracking Status
firefox80 --- verified

People

(Reporter: lwright, Assigned: andreio)

References

Details

Attachments

(6 files)

Chatted with @k88hudson about this briefly already. The Owned Media Network team is eager to test a one-scene send-to-device snippet template that provides a more direct path to downloading our mobile app, since we know we lose some people after the first click of our current two-scene template before they ever enter their email address or phone number. We think streamlining this will boost conversion rates.

The goal would be to get something in market as soon as possible so we can test with it, to help inform how we conduct our larger September moment campaigns.

A similar effort for the Firefox Lite (formerly Firefox Rocket) team was conducted previously that garnered positive results, but it doesn't appear that the send-to-device card "S2DC" template ever made it to ASR production. See Bug 1493065.

Ideally this template would be smaller than the current second-scene of our S2D template today, see attached screenshot (e.g. rather than having a large logo above the text, we could use a smaller logo to the left of the text like our standard snippets + the dismiss button/bar could be replaced by a hover-over 'x' like our standard one-scene snippets), but it would need to be larger than a simple snippet in order for the S2D form to fit.

Lisa, is this something you want to test in Firefox 80?

Flags: needinfo?(lwright)

Hi Tim, we'd need it for Firefox 80 (release date: 2020-08-25) at the very latest to have ready for our big 'September Moment' campaigns, but if it's possible to get sooner so we can test with it before then, that'd be ideal. Especially knowing it will require some time/work on Giorgos' end to expose the new template to the snippet service authoring tool in order for us to begin utilizing it.

Flags: needinfo?(lwright)
Assignee: nobody → andrei.br92
Iteration: --- → 80.2 - July 13 - July 26
Priority: -- → P1
Target Milestone: --- → Firefox 80

This will require the same fields as the S2D template for scene2 and the email / sms configuration fields (all listed below).

  scene2_title 
  scene2_text
  scene2_icon
  scene2_button_label
  scene2_input_placeholder
  scene2_dismiss_button_text
  scene2_disclaimer_html

   locale
   country
   include_sms
   message_id_sms
   message_id_email
   success_title
   success_text
   error_text
   retry_button_label

   block_button_text
   do_not_autoblock

I suggest that we don't include the Dismiss button and only display the block button as we do with the rest one-scene snippets.

What do you think Lisa?

(in this case we don't need scene2_dismiss_button_text)

Flags: needinfo?(lwright)

(In reply to Giorgos Logiotatidis [:giorgos] from comment #4)

I suggest that we don't include the Dismiss button and only display the block button as we do with the rest one-scene snippets.

What do you think Lisa?

(in this case we don't need scene2_dismiss_button_text)

Agreed! I provided my UI suggestions in the last paragraph of the description above.

"Ideally this template would be smaller than the current second-scene of our S2D template today, see attached screenshot (e.g. rather than having a large logo above the text, we could use a smaller logo to the left of the text like our standard snippets + the dismiss button/bar could be replaced by a hover-over 'x' like our standard one-scene snippets), but it would need to be larger than a simple snippet in order for the S2D form to fit."

Flags: needinfo?(lwright)

This is what I have so far. Can I please have some design help for placing the logo/additional image?

Flags: needinfo?(lwright)

Hi Andrei, thanks for the update! I'll connect with our OMN designer to mock-up what we're thinking and get back to you as soon as possible. We're actually hoping to make this even smaller/ more narrow.

Are you working against specific dates we should be aware of to ensure this gets in for Fx80? I don't want to cause any delays since we'll need it to ride that train.

Flags: needinfo?(lwright)

Hi Andrei,

I've attached two mock-ups for what we were thinking (one very similar to what you already had just with the "Let's do this!" headline removed, we don't think that will be necessary); the overall goal being to keep this as narrow as possible (with minimal padding on top and bottom).

v01: This is similar to what you already have with guidance on image placement.

v02: This one would actually be ideal, but I'm unsure if it's feasible. Might be too crammed / restrict the actual snippet copy character count too much.

One thing I wanted to note just to be sure it gets captured for either approach: post-"Send" click, someone should see a Success screen (assuming you've filled things out correctly and it doesn't throw an error message first, e.g. "Your download link was sent."), similar to the existing two-scene S2D template experience (I guess it's the third-scene in that case) -- I've attached a screenshot showing what I mean.

Hope this helps. Let me know if you have any questions!

Attached image Snippet_mockup_v01.png
Attached image Snippet_mockup_v02.png
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/01f3ce4e1942
Add new Snippets template for Send to Device r=k88hudson
Pushed by aoprea@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/759afe782909
Add new Snippets template for Send to Device r=k88hudson
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

I have verified this enhancement and I can confirm that I have managed to trigger the "SNIPPETS_SCENE2_SEND_TO_DEVICE_TEST" snippet from the "about:newtab#devtools" page and to successfully complete the flow.

Verified using the latest Firefox Nightly (80.0a1 Build ID - 20200723095657) installed on Windows 10 x64, Mac 10.15, and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Depends on: 1654802
Flags: needinfo?(andrei.br92)
Depends on: 1655452
You need to log in before you can comment on or make changes to this bug.