Closed Bug 1650211 Opened 3 months ago Closed 3 months ago

Crash in [@ mozilla::net::CookiePersistentStorage::EnsureReadComplete]

Categories

(Core :: Networking: Cookies, defect, P1)

79 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed
firefox80 --- fixed

People

(Reporter: philipp, Assigned: baku)

References

(Regression)

Details

(Keywords: crash, regression, Whiteboard: [necko-triaged])

Crash Data

Attachments

(1 file)

This bug is for crash report bp-40fa868f-465e-44b1-840d-1ae2a0200702.

Top 10 frames of crashing thread:

0 xul.dll mozilla::net::CookiePersistentStorage::EnsureReadComplete netwerk/cookie/CookiePersistentStorage.cpp:1719
1 xul.dll mozilla::net::CookieService::SetCookiesFromIPC netwerk/cookie/CookieService.cpp:2251
2 xul.dll mozilla::net::CookieServiceParent::RecvSetCookies netwerk/cookie/CookieServiceParent.cpp:175
3 xul.dll mozilla::net::PCookieServiceParent::OnMessageReceived ipc/ipdl/PCookieServiceParent.cpp:274
4 xul.dll mozilla::dom::PContentParent::OnMessageReceived ipc/ipdl/PContentParent.cpp:6285
5 xul.dll mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2093
6 xul.dll mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1972
7 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1234
8 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:504
9 xul.dll nsThread::Shutdown xpcom/threads/nsThread.cpp:898

this crash signature is somewhat increasing during the firefox 79 cycle - from the crash report it's not immediately clear to me what the underlying reason might be though.

baku, is this related with your recent changes? Can you please take a look?

Flags: needinfo?(amarchesini)

It seems that here we are adding a cookie during the shutdown. It could be that the CookiePersistentStorage has already been released. We can ignore this cookie replacing this assertion to a if-stmt:
https://searchfox.org/mozilla-central/rev/91d82d7cbf05a71954dfa49d0e43824c7c973e62/netwerk/cookie/CookieService.cpp#2247

Flags: needinfo?(amarchesini)
Assignee: nobody → amarchesini
Status: NEW → ASSIGNED
Severity: -- → S1
Priority: -- → P1
Whiteboard: [necko-triaged]
Severity: S1 → S2
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c067a02faf46
Ignore cookie settings during the shutdown, r=mayhemer
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

The patch landed in nightly and beta is affected.
:baku, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(amarchesini)

Comment on attachment 9161826 [details]
Bug 1650211 - Ignore cookie settings during the shutdown, r?mayhemer

Beta/Release Uplift Approval Request

  • User impact if declined: A crash can occur in debug builds.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): During the shutdown, cookies cannot be set because the CookieService could have been nullified already.
    This is a null check patch. Low risk.
  • String changes made/needed:
Flags: needinfo?(amarchesini)
Attachment #9161826 - Flags: approval-mozilla-beta?

Comment on attachment 9161826 [details]
Bug 1650211 - Ignore cookie settings during the shutdown, r?mayhemer

Approved for 79.0b8.

Attachment #9161826 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Blocks: 1656980
You need to log in before you can comment on or make changes to this bug.