Closed Bug 1651476 Opened 7 months ago Closed 3 months ago

Selected Folders in the Folder pane are not highlighted when using light theme (TB 79.0b1 +)

Categories

(Thunderbird :: Theme, defect)

All
macOS
defect

Tracking

(thunderbird_esr78 unaffected)

RESOLVED FIXED
84 Branch
Tracking Status
thunderbird_esr78 --- unaffected

People

(Reporter: de.berberich, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce:
Install Thunderbird 79.0b1-candidates/build2/ and create an account.
In the Folder Pane click with the mouse pointer on the account name or any folder name.

Expected result:
The account name or the selected folder name would be highlighted (get a specific background color).

Actual results:
There is no highlighting of the selected account or folder, whether it is in focus or not. The selected account or folder is not visually distinguished from other accounts or folders.
The same issue can be observed in the address book directory pane.

On my mac folder selection is shaded. However, I dont' see a focus ring. (perhaps it is too faint to see?)

Blocks: tb78found
Summary: Selected Folders in the Folder pane or not highlighted → Selected Folders in the Folder pane are not highlighted

Eckard tested Thunderbird 79.0b1-candidates/build2/. So not a tb78found bug?

You are right. Selected Folders are shaded when the "dark" or the "default" themes are used.
I forgot to mention that I still use the "light" theme.
The summary should be: Selected Folders in the Folder pane are not highlighted when the light theme is active.

It's a new bug in TB 79.0b1.
I just vérified v78.0b4 and this issue is not present when using the light theme.

Component: Folder and Message Lists → Theme
Summary: Selected Folders in the Folder pane are not highlighted → Selected Folders in the Folder pane are not highlighted when using light theme
No longer blocks: tb78found
Keywords: regression
Summary: Selected Folders in the Folder pane are not highlighted when using light theme → Selected Folders in the Folder pane are not highlighted when using light theme (TB 79.0b1 +)

(In reply to Wayne Mery (:wsmwk) from comment #1)

On my mac folder selection is shaded. However, I dont' see a focus ring. (perhaps it is too faint to see?)

I can reproduce this with 83 beta. I must not have used the light theme when I previously tested

regression range is https://hg.mozilla.org/releases/comm-beta/pushloghtml?fromchange=THUNDERBIRD_78_0b4_RELEASE&tochange=THUNDERBIRD_79_0b1_RELEASE&full=1

so perhaps we should suspect bug 1644730, which is listed in that regression range. But according to https://bugzilla.mozilla.org/show_bug.cgi?id=1644730#c14 this patch should have been on 78.0b2. What am I missing?

Flags: needinfo?(richard.marti)

Dossy, do you see this in 78 using light Thunderbird theme?

Flags: needinfo?(dossy)
Flags: needinfo?(richard.marti)
See Also: → 1594132

See also FX bug 1594132. Since bug 1644461 the vibrancy does no more work.
I enabled the light sidebar colours for Mac too now.

Additionally I ported bug 1673321 too in this patch.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9185058 - Flags: review?(alessandro)
Comment on attachment 9185058 [details] [diff] [review]
1651476-selected-treechildren-and-remove-old-macOS-css-code.patch

Review of attachment 9185058 [details] [diff] [review]:
-----------------------------------------------------------------

This doesn't seem to work for me.
I tested it on trunk and the selected folder still doesn't show an highlight background color.
Attachment #9185058 - Flags: review?(alessandro)

(In reply to Alessandro Castellani (:aleca) from comment #8)

Comment on attachment 9185058 [details] [diff] [review]
1651476-selected-treechildren-and-remove-old-macOS-css-code.patch

Review of attachment 9185058 [details] [diff] [review]:

This doesn't seem to work for me.
I tested it on trunk and the selected folder still doesn't show an highlight
background color.

Was the light theme already selected before you built with the patch? Then you need to disable/enable the light theme to apply the theme changes. It seems there is a cached version used. I don't know how we could fix this update issue. Maybe with a theme version change to 1.1.1?

Tried with the version change to 1.1.1 but this didn't work.

Comment on attachment 9185058 [details] [diff] [review]
1651476-selected-treechildren-and-remove-old-macOS-css-code.patch

Indeed, you were right. I had the light theme already selected when applying the patch.
This fixes the missing highlight color, thanks.

Attachment #9185058 - Flags: review+
Target Milestone: --- → 84 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/c8d716c35cb0
Fix folderTree selected items and port bug 1673321: Remove theme CSS for macOS 10.11 and below. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Flags: needinfo?(dossy)
You need to log in before you can comment on or make changes to this bug.