Closed Bug 1653209 Opened 2 years ago Closed 2 years ago

TB 78.0b4 - Extremely slow address book search with large global AB (360,000 entries)

Categories

(Thunderbird :: Address Book, defect)

defect

Tracking

(thunderbird_esr78+ affected)

RESOLVED DUPLICATE of bug 1658062
Tracking Status
thunderbird_esr78 + affected

People

(Reporter: brenboy78, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, regression, Whiteboard: [dupme])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

Thunderbird version: 78.0b4
Add-on versions: Owl 0.76
OS version: MacOS 10.15.6
Hardware version:
MacBook Pro (2018)
2.2GHz 6-core Intel Core i7
16GB 2400Mhz DDR4 RAM

What did you do? (steps to reproduce): Upgraded from TB 68.10.0 to 78.0b4. It was observed that 78.0b4 was very slow to load (>15 minutes). After eventually loading and attempting to write an email, TB would hang whilst trying to match on a contact in the Default Global Address List. MacOS would report TB as 'Application Not Responding'. After > 30 minutes, the Default Global Address List would return the correct email address.

This can also by reproduced by clicking on Window -> Address Books -> Default Global Address List.

My Default Global Address List has ~358,000 entries (all personal email addresses and email group aliases used within my company).

This issue was not seen in TB 68.10.0 with the same Default Global Address List.

The same behaviour was also observed in 78.0b3. No other 78 beta versions were used.

Actual results:

MacOS would report TB as 'Application Not Responding'. After > 30 minutes, the Default Global Address List would return the correct email address.

Expected results:

TB should have returned a matching email address very quickly (< 5 seconds).

Priority: -- → P2
Blocks: tb78found
Component: Untriaged → Address Book
Keywords: perf
Priority: P2 → --
Summary: TB 78.0b4 - Extremely slow address book search → TB 78.0b4 - Extremely slow address book search with large global AB (360,000 entries)
Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regressed by: 1572324

I think Bug 1590237 is also relevant

Keywords: regression

This defect also causes TB 78 to take more than 30 minutes to load. After deleting the Default Global Address List with 360k entries TB 78 loads in under a minute.

(In reply to Bren from comment #3)

After deleting the Default Global Address List

Is this an addressbook that your company supplies? If not, how have you populated an addressbook with 360k entries?

(Thunderbird doesn't a name of "Global Address List, only "All address books", "collected addresses", and "personal address book")

Flags: needinfo?(brenboy78)

Is this an addressbook that your company supplies? If not, how have you populated an addressbook with 360k entries?

The address book only contained company email addresses (personal and group email aliases) so it must be something that my company supplies. I can't remember how I got it.

I tried to rebuild that address book by going to Preferences -> Composition -> Addressing -> Edit Directories and running Download Now under Offline but it doesn't rebuild it.

Flags: needinfo?(brenboy78)

Ah, so you downloaded a massive ldap directory.

Why do you feel the need to do that? The great advantage of ldap is you don't need to maintain the address book (someone else does), you don't need it locally, and it scales to large size.

I'm saying I don't know how I got that list :)

I assumed it was via LDAP but I can't pull the list down that way now.

In any event, your performance issue should be mitigated by 80.0b3 which came out early this week.

Flags: needinfo?(brenboy78)
Whiteboard: [dupme]

Likely bug 1658062. If you still see a problem after using a current beta please give a shout.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(brenboy78)
Resolution: --- → DUPLICATE
Duplicate of bug: 1658062
You need to log in before you can comment on or make changes to this bug.