Closed Bug 1653793 Opened 2 years ago Closed 1 year ago

TB 78: startup error in error console. TypeError: singletons is null, init resource://gre/modules/ActorManagerChild.jsm:297

Categories

(Thunderbird :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: ishikawa, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

I installed TB 78 (32-bit), Japanese locale version, a few days ago under Windows 10 (64-bit)
I noticed the error reported here in error console immediately after startup of the program (no interaction after the startup).
(See Bug 1653789, TB 78.0: Errors in error console immediately after startup of TB under Windows 10.)

However, this particular error seems to be caused by async race.
Sometimes I see it, and other times I don't.

TypeError: singletons is null
 
   init resource://gre/modules/ActorManagerChild.jsm:297
    <匿名> resource://gre/modules/ActorManagerChild.jsm:349
    <匿名> chrome://global/content/browser-content.js:12
    get browsingContext chrome://global/content/elements/browser-custom-element.js:627
    setFindbarInActor chrome://global/content/elements/findbar.js:316
    set browser chrome://global/content/elements/findbar.js:326
    connectedCallback chrome://global/content/elements/findbar.js:163

"<匿名>" in the above quote would be "<anonymous>" in English locale.

Blocks: 1653789
Blocks: tb78found

Is this still happening?

Flags: needinfo?(ishikawa)

(In reply to Alessandro Castellani [:aleca] from comment #1)

Is this still happening?

No, as the attached screen dump shows, it is gone.
I have switched to 78.8.0 (32-bit) and so something must have fixed it for now.

Flags: needinfo?(ishikawa)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.