Open Bug 1653789 Opened 3 years ago Updated 2 months ago

TB 78.0: Errors in error console immediately after startup of TB under Windows 10

Categories

(Thunderbird :: General, defect)

x86_64
Windows 10
defect

Tracking

(Not tracked)

People

(Reporter: ishikawa, Unassigned)

References

Details

Attachments

(15 files)

229.89 KB, image/png
Details
7.06 KB, text/plain
Details
7.17 KB, text/plain
Details
600.24 KB, image/png
Details
463.20 KB, image/png
Details
620.97 KB, image/png
Details
478.19 KB, image/png
Details
758.74 KB, image/png
Details
810.11 KB, image/png
Details
811.61 KB, image/png
Details
793.22 KB, image/png
Details
837.42 KB, image/png
Details
177.20 KB, image/png
Details
204.26 KB, image/png
Details
201.33 KB, image/png
Details

I installed TB 78 (32-bit), Japanese locale version, a few days ago under Windows 10 (64-bit)

I noticed to my surprise that there are seriously looking errors reported in error console immediately after startup of the program (no interaction after the startup).

I looked in the error console since somehow I trashed my profile(?) and no predefined tags such as "To Do" were available.: my custom-defined tags such as "handled already", "checkin-needed", etc. were there. Strange.

Anyway I am attaching the screen capture of error console immediately after the startup of TB78 (32-bit) under Windows 10 pro (64-bit).

I will file separate bugs for the errors in the error console and have them block this entry.

All the errors except for the simpleton error are present in the safe mode startup as well.

Well, this is probably because the error of simpleton seems to be caused by async race and may not happen all the time.
So I will not deny the possibility this simpleton error happens in safe-mode even.

Depends on: 1634341
Depends on: 1653792

The simpleton error seems to be caused by asynchronous race.
Sometimes I see it, other times I don't. :-(

Depends on: 1653793
Blocks: tb78found

FYI, console errors appears as well in TB 80.0b1 (64-bits) with a blank profile set up.
See attached.

(keeping meta bug 1644037 focused on user facing issues)

No longer blocks: tb78found

Do you still see this issue?

I'm not seeing these in a current en-US version 102

Flags: needinfo?(ishikawa)

On my home PC (Windows 10 Pro), I am still on 91.11.0 (64-bit).

There I still get the error regarding the L10nRegistry immediately after the startup.
I think the errors in the green rectangle I marked are related to the currently disabled add-ons that are no longer available or something. (I had to re-install windows10 early this year, and I may have messed up the add-ons for TB, but I am not sure.)

I found a mention to the same error in bug 1462839 comment 10
In that case, it was 78.10.2 (64-bit).

So it has been with TB for quite some time, I think.

I have no idea if the localization for me (Japanese locale) may have something to do with it.
But I have no idea what the locales used by others who reported the issues.

BTW, this is supposed to be fixed by bug 1634341

So once I get the 102.xx.yy version (JP locale) distributed automatically on my Windows, then I can confirm the bug status.

Flags: needinfo?(ishikawa)
Flags: needinfo?(ishikawa)
Flags: needinfo?(ishikawa)

So once I get the 102.xx.yy version (JP locale) distributed automatically on my Windows, then I can confirm the bug status.

good results?

Flags: needinfo?(ishikawa)

I have now 102.5.0 64-bit on my Windows 10 PRO PC.
Actually, TB updated itself just about 10 minutes ago, and I am looking at the error console now without doing anything else.

There ARE new error messages, but not the previous one reported. They are probably fixed.
Good.

The bad news is that the new error messages look bad or troubling enough.
Since there are so many of them and it won't fit into one screenful worth of image when the error messages are expanded, I am splitting the view into two chunks and post them separately.

I did not bother to expand the last db.folder is null error., but it contained the same error lines as previous ones.

These probably need to be investigated since obviously, the invalid path error in the second image
caused a cascading error, it seems.
Since OpenFilterList could not get a line, curFilterList seems to be null, for example.

I searched for "db.folder is null", and found Bug 1792071 filed two months ago.
So, this could be a cause of serious bugs [or symptoms] (?)

In the previous image, the one about "Component returned failure code: 0x80550013 [nsIMsgPluggableStore.createFolder]" is a bit disturbing. Is it possible there is a problem in my not often used account regarding default mailboxes!?

The about "Error: Can't find profile directory" is also disturbing.
I am not sure if it refers to user profile or
maybe a performance profiling data?

"Unknown Collection "thunderbird/password-recipes" is also a suspect.
I have seen my share of unknown collection errors in local xpcshell and mochitest logs, but I have never seen this "password-recipes" error.
For like last 20 months, I have seen the following errors on/off in my LOCAL log files. During that time, the line # has changed. So some collection messages appear twice.

"Unknown Collection "thunderbird/hijack-blocklists"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 192}]
"Unknown Collection "thunderbird/partitioning-exempt-urls"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 158}]
"Unknown Collection "thunderbird/partitioning-exempt-urls"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 160}]
"Unknown Collection "thunderbird/url-classifier-skip-urls"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 158}]
"Unknown Collection "thunderbird/url-classifier-skip-urls"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 160}]

The one about PDF written in Japanese error message warrants explanation.
I was reading a PDF attachment in the previous TB session when update was prompted.
So a PDF file was opened in a tab after TB updated itself. So this is not a general error associated with simply starting TB, but more like the PDF.js problem.

Flags: needinfo?(ishikawa)

Comment on attachment 9304025 [details]
This is the error console after quitting the updated TB and restarting from scratch.

Good news is that there less errors in error console when
I quit the updated TB completely and re-started from scratch.

But I would like the previous errors that were recorded when the updated TB started up for the first time.
This is because I often use TB after automatic updating, and if some data structure is NOT properly initialized in such a state (according the errors I see in the error console), the TB operation may not proceed error-free and strange things may ensue.
I was wondering if the failure to filter some mails properly (I see unfiltered messages now and then in my main Inbox)
could be related to such issues on top some folders being left locked and filtering could not take place, etc.

TIA

Attachment #9304025 - Attachment description: This is the error console after quiting the updated → This is the error console after quitting the updated TB and restarting from scratch.

This is not about the errors that appeared immediately after the TB startup, but
some errors that appear repeatedly while I was not looking at the error console.
I only fetched e-mails a few times, and wrote several e-mails during that time.
I am uploading a few other screenshots and see where I should file the bugs.
Right now, I am tied up with day work and cannot file the bugzillas separately.

assertion failure and
uiConv is undefined are errors. (The latter sounds bad for Japanese users. It suggests character conversion failure somewhere?)

Attached image more errors: 3rd

Lots of similar errors continued.

Attached image more errors: 4th

Suddenly I get flurry of nsIDocShell.domWindow NS_ERROR_NOT_AVAILABLE.
So many red lines that caught my eyes.

Attached image More errors: 5th

I think this is where I wrote a message and eventually sent it. (In this error window, I have not sent it out yet.)

I have no idea what caused this series of errors.

See the time stamp.
I realize that I can cause the errors in the screen to occur by expanding and collapsing e-mail thread.

I will keep this TB session as long as possible so that if someone wants to get more data, I can try.

This is the somewhat detailed view of the first error generated when I tinkered with message thread.

Is it possible that I am running out of memory?
If so, I would like to see "Low memory" or some such phrase somewhere in the stack or error message itself. :-(
(PC has 32GB memoru, but now I am using 31.1GB and remaining is 850MB, already commited 43.4/63.2 according to task manager of Windows 10 PRO).

Again, I am leaving the TB session running so that I can recreate the error and obtain more data (just tell me how) if anyone is interested in debugging this.

TIA

You need to log in before you can comment on or make changes to this bug.