Closed Bug 1653837 Opened 2 years ago Closed 2 years ago

Upgrade to TB78, UI changes on mouseover but unresponsive to mouse or keyboard. High CPU, high memory, high disk

Categories

(Thunderbird :: General, defect, P1)

x86_64
Windows 10

Tracking

(thunderbird_esr78+ affected)

RESOLVED WORKSFORME
Tracking Status
thunderbird_esr78 + affected

People

(Reporter: unicorn.consulting, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf)

Attachments

(1 file)

Ran the upgrade to V78 against my regular Thunderbird account. Lots of accounts, lots of folders and most of all plenty of non-functional accounts due to me not having time to follow up passwords with some providers.

The install took an exceedingly long time and resulted after more than 30 minutes in a user interface that contained nothing in the folder pane, a menu bar and toolbar that did not respond to user input but did respond to mouse-overs.

My notes on the upgrade process including images taken of memory use and thunderbird's appearance post upgrade can be seen here https://thunderbirdtweaks.blogspot.com/2020/07/my-experience-in-updating-to.html

Bug 1625874 would be a duplicate, except I had no issues with any of the V68 releases

This is a profile-specific issue I think as I have been running various versions of Daily over many months with a single account profile and no contacts or Calendars on this same device without any serious issues of the type mentioned in my upgrade to my profile.

The workarounds from Bug 1625874 also did not help with this issue.

Dupe of bug 1652279?

Looked at that first Jorg, at Waynes suggestion, but I do not think so. It could be involved and I am following so I can have another go when the fix is in for it, I am not discounting it entirely.

With enough clicking of stalled scripts the UI does load, empty as in bug 1625874. But the menu and toolbar does change highlighting (focus) on mouseover and clicking the main menu bar makes those little squares, which might be tooltips, or might be a menu if the scaling was not all wrong. Shortcut keys do not appear to work. That the status bar reports mail being received in the background makes me think not a duplicate.

Safe mode has no issues loading the safe mode dialog and resetting toolbars did work as when I went back to 68 all toolbar personalisations were missing.

So yes the delayed start and 5 continue script dialogs is probably bug 1652279. The end result I do not think is that bug as the UI appears to be fully rendered, there is negligible memory disk or network activity and background tasks like getting mail appear to work.

See Also: → 1652279
Summary: Tried to upgrade to V78 user interface to all intents and purposes unresponsive to mouse of keyboard. → While trying to upgrade to TB78, user interface unresponsive to mouse or keyboard

Gone in 78.1.0 ?

Flags: needinfo?(unicorn.consulting)

78.1 has allowed the profile to load. But I am still seeing around 7 minutes to load and repeated timeouts. Given Bug 1652279 is apparently fixed in 78.1 I am at something of a loss. I am also somewhat reluctant to restart to fix things as I get about 4 restarts an hour.

The load appears to entirely stop with each script timeout and only restarts after I click continue. I did note memory use around 3.5 - 4Gb and disk IO peaking around 30mb/sec when everything appears to load into virtual memory because the program has used all available physical memory. Then a timeout will occur. 8Gb of memory should be enough for a browser and mail client, but not ones built on Mozilla technologies apparently, with Thunderbird wanting around 3Gb and firefox regularly consuming more than 1.5Gb.

Flags: needinfo?(unicorn.consulting)

Could be a challenge. I attempted to find a similar report for bugs filed this year

No RSS accounts, and also fails in Windows and Thunderbird safe mode?

One starting point is determine whether it happens with a daily build prior to 2020-06-07 where Bug 1637668 landed.

Severity: -- → S2
Flags: needinfo?(unicorn.consulting)
Keywords: perf
Summary: While trying to upgrade to TB78, user interface unresponsive to mouse or keyboard → Upgrade to TB78, UI changes on mouseover but unresponsive to mouse or keyboard. High CPU, high memory, high disk

Just wanted to add that 64 bit version has the same issues. I don't see a place to check that off anywhere under details or references up above.

Installing 78.0.1 does appear to have made things work and 78.1 removed the long delays. I had it wrong last time. Was only when the 78.1 auto-update appeared that I realised it was not what I installed.

Now I just have to wait I hope for a fix to the address book. Can't send mail because I don't have one. Just a dandy upgrade I am having.

Flags: needinfo?(unicorn.consulting)

(In reply to Matt from comment #7)

Now I just have to wait I hope for a fix to the address book.

Does your missing address book match the description of bug 1655686 ?

Flags: needinfo?(unicorn.consulting)

Have just installed 78.1.1 so that is pretty up to date on released versions.

No Wayne, I can not find any ...

I am attaching a directory listing for my profile for files names abook*.* just in case you can see something I can not.

Where are these preferences in prefs.js? Perhaps I can determine what is missing by verifying the folders in the preferences.

Opening a write window consistently places the following errors in the error console.

NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue] AddrBookManager.jsm:192

Exception { name: "NS_ERROR_NOT_INITIALIZED", message: "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue]", result: 3253927937, filename: "resource:///modules/AddrBookManager.jsm", lineNumber: 192, columnNumber: 0, data: null, stack: "get directories/<@resource:///modules/AddrBookManager.jsm:192:25\nget directories@resource:///modules/AddrBookManager.jsm:190:10\n_rebuild@chrome://messenger/content/addressbook/menulist-addrbooks.js:136:22\nconnectedCallback@chrome://messenger/content/addressbook/menulist-addrbooks.js:34:12\n@chrome://global/content/customElements.js:217:21\n", location: XPCWrappedNative_NoHelper }
customElements.js:220:19

None of my addons like compact header apparently interact with the three pane window although safe mode does not appear to change the dewfault missing header information, nor does it make an address book appear that I can use.

Attempts to send an email already copmposed from draft produces the following three errors

NS_ERROR_NOT_INITIALIZED: Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue] AddrBookManager.jsm:200
get directories/< resource:///modules/AddrBookManager.jsm:200
comparefn self-hosted:212
InsertionSort self-hosted:3592
MergeSort self-hosted:3644
sort self-hosted:200
get directories resource:///modules/AddrBookManager.jsm:198
expandRecipients chrome://messenger/content/messengercompose/MsgComposeCommands.js:6970
GenericSendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:4365
SendMessage chrome://messenger/content/messengercompose/MsgComposeCommands.js:4832
doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:961
doCommand chrome://messenger/content/messengercompose/MsgComposeCommands.js:1157
goDoCommand chrome://global/content/globalOverlay.js:101
oncommand chrome://messenger/content/messengercompose/messengercompose.xhtml:1

Uncaught
Exception

columnNumber: 0

data: null

filename: "resource:///modules/AddrBookManager.jsm"

lineNumber: 200

location: XPCWrappedNative_NoHelper { QueryInterface: QueryInterface(), filename: Getter, name: Getter, … }

message: "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue]"

name: "NS_ERROR_NOT_INITIALIZED"

result: 3253927937

stack: "get directories/<@resource:///modules/AddrBookManager.jsm:200:25\nget directories@resource:///modules/AddrBookManager.jsm:198:10\nexpandRecipients@chrome://messenger/content/messengercompose/MsgComposeCommands.js:6970:15\nGenericSendMessage@chrome://messenger/content/messengercompose/MsgComposeCommands.js:4365:5\nSendMessage@chrome://messenger/content/messengercompose/MsgComposeCommands.js:4832:21\ndoCommand@chrome://messenger/content/messengercompose/MsgComposeCommands.js:961:11\ndoCommand@chrome://messenger/content/messengercompose/MsgComposeCommands.js:1157:9\ngoDoCommand@chrome://global/content/globalOverlay.js:101:18\noncommand@chrome://messenger/content/messengercompose/messengercompose.xhtml:1:12\n"

<prototype>: ExceptionPrototype { toString: toString(), name: Getter, message: Getter, … }
AddrBookManager.jsm:200

An error occurred executing the cmd_sendButton command: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIAbDirectory.getIntValue]" nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)" location: "JS frame :: resource:///modules/AddrBookManager.jsm :: get directories/< :: line 200" data: no] globalOverlay.js:104
goDoCommand chrome://global/content/globalOverlay.js:104
oncommand chrome://messenger/content/messengercompose/messengercompose.xhtml:1

Flags: needinfo?(unicorn.consulting)

If confirmed, comment 9 will deserve a new bug report, but since it is here ...

  1. Is dash in the address book name an issue?
  2. Does Matt's error console indicate general AB failings, or checks needed in the migration process?
Flags: needinfo?(geoff)
Priority: -- → P1

Could these errors be coming from your Windows address book, which ISTR you use? I can't think how else you'd get NS_ERROR_NOT_INITIALIZED from the part of the code mentioned above.

Flags: needinfo?(geoff) → needinfo?(unicorn.consulting)

(In reply to Geoff Lankow (:darktrojan) from comment #12)

Could these errors be coming from your Windows address book, which ISTR you use? I can't think how else you'd get NS_ERROR_NOT_INITIALIZED from the part of the code mentioned above.

Looks like you hit on it for me. I have been pressed for time and finally got to remove it. I was rushed, but there was a pref for the address book file name, I was so busy just resetting them that I did not take notice what it was. But it was not one of the original three I set to implement the windows address book.

I will try to re-implement in the next few days and see if I can work out if it was the address book file name artifact or if the Windows address book is just broken (I did test the daily at the time and it worked)

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(unicorn.consulting)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.