Closed Bug 1653870 Opened 1 year ago Closed 1 year ago

Windows 10: Open Address book from jump list not working (== command line argument -addressbook doesn't work)

Categories

(Thunderbird :: OS Integration, defect)

Unspecified
Windows
defect

Tracking

(thunderbird_esr60 unaffected, thunderbird_esr68 unaffected, thunderbird_esr78 fixed, thunderbird68 unaffected, thunderbird69 unaffected, thunderbird70 unaffected, thunderbird71 unaffected, thunderbird72 unaffected, thunderbird73 unaffected, thunderbird74 unaffected, thunderbird75 wontfix, thunderbird76 wontfix, thunderbird77 wontfix, thunderbird78 affected, thunderbird79 affected, thunderbird80 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr60 --- unaffected
thunderbird_esr68 --- unaffected
thunderbird_esr78 --- fixed
thunderbird68 --- unaffected
thunderbird69 --- unaffected
thunderbird70 --- unaffected
thunderbird71 --- unaffected
thunderbird72 --- unaffected
thunderbird73 --- unaffected
thunderbird74 --- unaffected
thunderbird75 --- wontfix
thunderbird76 --- wontfix
thunderbird77 --- wontfix
thunderbird78 --- affected
thunderbird79 --- affected
thunderbird80 --- fixed

People

(Reporter: ak.bugzilla, Assigned: darktrojan)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.89 Safari/537.36 Edg/84.0.522.40

Steps to reproduce:

Right click on the taskbar icon. Select "Open address book" from the jump list.

Actual results:

Nothing...

Expected results:

Should open the address book.
"Write new message" entry in the jump list is working fine.

OS: Unspecified → Windows

Anje, can you confirm?

Flags: needinfo?(anjeyelf)

Confirmed. But the issue is that the command line argument -addressbook doesn't work which is used by the jumplist, -compose still works.

Geoff, do you know what could be the problem with the command line argument?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(geoff)
Flags: needinfo?(anjeyelf)

Wayne - currently on 68.10.0 and About > Thunderbird says I'm up to date, so auto update has not occurred as yet.
But I will keep an eye on this.

Assignee: nobody → geoff
Summary: Windows 10: Open Address book from jump list not working → Windows 10: Open Address book from jump list not working (== command line argument -addressbook doesn't work)

Windows 10 1909
Confirm: right click on icon in taskbar - select : open address book
version 68.10.0 works
version 78.0.1 fails

Blocks: tb78found

Hmm, yes, it appears I did remove that.

Status: NEW → ASSIGNED
Flags: needinfo?(geoff)

This is a port of https://hg.mozilla.org/comm-central/rev/d575c65cb9ea#l19.1314 which I should've done at the time.

Attachment #9166189 - Flags: review?(khushil324)
Comment on attachment 9166189 [details] [diff] [review]
1653870-addressbook-commandline-1.diff

Review of attachment 9166189 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. r=khushil
Try-run: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=789dd7931f27a3f84a9a9cc63605833e7132db21
Attachment #9166189 - Flags: review?(khushil324) → review+
Attachment #9166189 - Flags: approval-comm-esr78?
Attachment #9166189 - Flags: approval-comm-beta?

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/74e0cebeb9a0
Reinstate --addressbook command-line handler. r=khushil

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Comment on attachment 9166189 [details] [diff] [review]
1653870-addressbook-commandline-1.diff

Approved for beta
Attachment #9166189 - Flags: approval-comm-beta? → approval-comm-beta+
Comment on attachment 9166189 [details] [diff] [review]
1653870-addressbook-commandline-1.diff

[Triage Comment]
Approved for esr78
Attachment #9166189 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.