Closed Bug 1654628 Opened 6 months ago Closed 5 months ago

Port WebDriver:SwitchToFrame and WebDriver:SwitchToParentFrame to JSWindowActor

Categories

(Testing :: Marionette, task, P1)

task

Tracking

(Fission Milestone:M6c, firefox81 fixed)

RESOLVED FIXED
81 Branch
Fission Milestone M6c
Tracking Status
firefox81 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

Details

(Whiteboard: [marionette-fission-mvp])

Attachments

(2 files)

With bug 1654454 we have support for WebDriver:FindElement, and WebDriver:FindElements. It means we can port WebDriver:SwitchToFrame over to the JSWindowActor implementation.

Summary: Port WebDriver:SwitchToFrame to JSWindowActor → Port WebDriver:SwitchToFrame and WebDriver:SwitchToParentFrame to JSWindowActor

Because our element store is still in the content process, existing tests will start failing because not only each frame gets it's own store but also each navigated page because new actors are getting spawned. As such bug 1654513 is needed to get it fixed.

Maja, I wonder if we want to get it landed anyway even with the known caveat from above. What do you think? Happy to also discuss in a meeting.

Flags: needinfo?(mjzffr)

Fine with landing it. We should keep track of tests that are expected to fail wherever possible (based on the marionette.fission.enable pref). Unfortunately, wpt doesn't allow to set expectation conditional on a pref.

Flags: needinfo?(mjzffr)

Another option would be to delay landing the second patch and simply accept that all tests regarding frame switching will fail. It should be easier to disable wdspec tests based on that.

I turns out that delaying the landing of the second patch will cause even more problems given that more tests exist that make use of the WebDriver:switchTo(Parent)Frame command, so all other commands will fail compared to only the element affected ones. I suggest we just land both now and have the element store patch for parent ready soon. Note, that we still have everything behind a pref, so nothing in CI will be affected for now.

Whiteboard: [marionette-fission-mvp]
Attachment #9165687 - Attachment is obsolete: true
Fission Milestone: --- → M6c
Attachment #9165687 - Attachment is obsolete: false
Attachment #9165687 - Attachment description: Bug 1654628 - [marionette] Simplify handling of current frame and browsing context in GeckoDriver. → Bug 1654628 - [marionette] Ease handling of browsing context and current window.
Attachment #9165687 - Attachment description: Bug 1654628 - [marionette] Ease handling of browsing context and current window. → Bug 1654628 - [marionette] Ease handling of browsing contexts and current window.
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0883c2b689df
[marionette] Ease handling of browsing contexts and current window. r=marionette-reviewers,maja_zf
https://hg.mozilla.org/integration/autoland/rev/627409e8dc76
[marionette] Port WebDriver:SwitchToFrame and WebDriver:SwitchToParentFrame to JSWindowActor. r=marionette-reviewers,maja_zf
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Duplicate of this bug: 1580700
You need to log in before you can comment on or make changes to this bug.