Closed Bug 1655065 Opened 2 years ago Closed 2 years ago

eslint gets installed every time I run mach eslint

Categories

(Firefox Build System :: Lint and Formatting, task)

task

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1653195

People

(Reporter: mccr8, Unassigned)

References

(Blocks 1 open bug)

Details

If I do mach eslint --fix <file name> then it installs eslint:

osx:~/mc % ./mach eslint --fix toolkit/components/aboutmemory/tests/browser/browser_about_memory.js
eslint-visitor-keys v1.3.0 should be v1.2.0.
Installing eslint for mach using "/Users/andrewmccreight/.mozbuild/node/bin/node /Users/andrewmccreight/.mozbuild/node/bin/npm ci --loglevel=error --scripts-prepend-node-path"...

eslint installed successfully!

NOTE: Your local eslint binary is at /Users/andrewmccreight/mc/node_modules/.bin/eslint

If I run the same command again, it reinstalls it. This makes running eslint slower.

Please check your tree is up to date, this was fixed in bug 1653195.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1653195

Thanks. I updated my tree a few days ago, but I apparently forgot to rebase.

You need to log in before you can comment on or make changes to this bug.