Closed Bug 1656360 Opened 3 months ago Closed 3 months ago

Mochitest failures due to AccountWizard opening as modal.

Categories

(Thunderbird :: General, defect, P1)

Tracking

(thunderbird_esr78 fixed, thunderbird80 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird80 --- fixed

People

(Reporter: aleca, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

TEST-UNEXPECTED-FAIL | comm/mail/test/browser/account/browser_mailAccountSetupWizard.js | Uncaught exception - at resource://testing-common/mozmill/utils.jsm:127 - TimeoutError: Timeout waiting for modal dialog to open.
Log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=311549070&repo=comm-central&lineNumber=1880

TEST-UNEXPECTED-TIMEOUT | comm/mail/test/browser/newmailaccount/browser_newmailaccount.js | application timed out after 370 seconds with no output
Log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=311549102&repo=comm-central&lineNumber=3181

Status: NEW → ASSIGNED
Keywords: regression

We can't currently use the emailWizard as modal due to the way it was originally designed.
We have plans to drop this dialog entirely in the future anyway, so better revert back the change and avoid multiple issues.

Attachment #9167160 - Flags: review?(geoff)
Severity: -- → S2
Priority: -- → P1
Comment on attachment 9167160 [details] [diff] [review]
1656360-tests.diff

I'll ship this now.
Attachment #9167160 - Flags: review?(geoff) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/e4234b47d041
Fix TimeoutError test failures when interacting with the emailWizard. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Comment on attachment 9167160 [details] [diff] [review]
1656360-tests.diff

[Approval Request Comment]
Regression caused by (bug #): bug 1655289
User impact if declined: broken tests and broken manual config during account setup
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #9167160 - Flags: approval-comm-esr78?
Attachment #9167160 - Flags: approval-comm-beta?

Comment on attachment 9167160 [details] [diff] [review]
1656360-tests.diff

[Triage Comment]
Approved for beta

Attachment #9167160 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9167160 [details] [diff] [review]
1656360-tests.diff

[Triage Comment]
Approved for esr78

Attachment #9167160 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.