Closed Bug 1657443 Opened 1 year ago Closed 1 year ago

sw-wr: YouTube video shows multiple frames and other image clipping problems

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- disabled
firefox82 --- verified

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image YouTube_screenshot.jpg

Steps to reproduce

  1. Set gfx.webrender.software pref = true.
  2. Load https://www.youtube.com/watch?v=Y9KyBdPeKHg
  3. Play the video.

Actual result

The video shows multiple small frames along the top of the video and then other image clipping problems. See the attached screenshot.

If I reset gfx.webrender.software to false, the problem appears to go away.

I bisected this regression to the following pushlog, which includes to three different WebRender bugs. I assume this regression is caused by bug 1653166 because I'm on Windows and the other two bugs mention macOS.

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4ed6ec0c8220321b13c108ffaa7ab6cfc8d7698f&tochange=4558b3cfd6fe49647780a0ec86dfa97f0dd3adcb

Attached file My about:support
See Also: → 1657107
See Also: → 1657428
Summary: sw-wr: YouTube video shows multiple frames and other image clipping problemsw → sw-wr: YouTube video shows multiple frames and other image clipping problems

Marking as S3 since this isn't enabled yet

Severity: -- → S3
Priority: -- → P3
See Also: 1657312

Is this fixed now? I landed some changes to support scaling properly for SWWR in bug 1657771.

(In reply to Matt Woodrow (:mattwoodrow) from comment #3)

Is this fixed now? I landed some changes to support scaling properly for SWWR in bug 1657771.

No. The video is still broken with SWWR, but in a different way. See this new screenshot.

Closing as WORKSFORME because I can no longer reproduce this bug.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Like bug 1659369, I suspect this bug was fixed by SwCompositor bug 1622966.

This bug might still be present in the slow path which kicks in when WR cannot layerize the video.

You need to log in before you can comment on or make changes to this bug.